[PlanetCCRMA] stuck!! nvidia & ccrma

nigel henry cave.dnb@tiscali.fr
Sat Jun 24 10:43:01 2006

On Saturday 24 June 2006 18:08, csynan wrote:
> Friends, I desperately need some help or advice.  I have been using linux
> exclusively at home since RH6 and this is by FAR the most frustrated I have
> ever been.  Since upgrading to FC5 my system has been all messed up.  I
> have been struggling with this for two weeks.
> FC5 ccrma works fine, but I just can't get nvidia drivers working.  And it
> even seems to break other things.  I have tried rdt and rrt kernels.  I
> have tried building nvidia the way I always have.  After editing xorg.conf
> (and loading the module) it wont start X.  even when I change the driver
> back to "nv", when gnome finally starts (takes like 180 sec), it is all
> messed up and my windows don't have a title bar, they are all fixed to the
> top of the screen.
> If I use the regular FC5 kernel I can get the livna kernel module to work,
> but then I have no ALSA.
> I even tried ubuntu, but I could not get my echoaudio stuff working, even
> when i built it myself & it loaded properly into the kernel (showed up in
> lsmod), echomixer still said "no echoaudio cards found, sorry".  Now I am
> back on my 8th reinstall of FC5, and once again, I am stuck.  Right now I
> am back to rrt kernel, and gnome is all messed up under "nv" and no GLX.
> Please someone give me some direction.  Any solution that gives me nvidia
> drivers, and realtime kernel, and alsa-firmware / alsa-drivers would be
> great.  I had all this working fine in CCRMA / FC4, so i know it can be
> done.
> One other thing, when I run the nvidia installer, after it builds, there
> are a bunch of garbled messages spewing across the screen, looks like it
> has to do with SELinux because it is saying "granted" and "denied" and
> stuff like that.  My guess is something the nvidia installer is trying to
> do is running afoul of SELinux and SElinux is not letting the necessary
> change take place.  maybe i will try disabling SELInux and see if that
> fixes it.
> thanks in advance for any pointers or help.

Hi. Just one thought really. I have seen a lot of posts on Fedora mailing list 
to do with Selinux interfering with installs. Personally I don't use it, and 
would suggest disabling it, perhaps temporarily, and trying again.

I read quite a while back an article about security. The conclusion was that 
being secure is a good thing, and not to be ignored. But too much security, 
due to paranoia, or whatever, can prevent you from using your machine as you 
want to. I read some of SELinux for dummies.

Setting this up properly is not a Joe user thing. No just point and click. To 
me this was quite complex. Have a read and see what you think.

Hope you get FC5 working as you want it.