[PlanetCCRMA] Need "options" for /etc/modprobe.conf for audigy (hw0) and USB keyboard (hw1)

nigel henry cave.dnb@tiscali.fr
Mon Jan 17 06:19:02 2005

Hi Fernando and everyone that's helped with this problem.
Pasi Karppinen sent me the output from his FC1's /etc/modules.conf with
suggested lines to add. I added these to my FC2's /etc/modprobe.conf as
shown below on my updated /etc/modprobe.conf and it all boots up ok now
with cat /proc/asound/cards showing the Evolution 225C midi keyboard in
second place. I also updated /etc/modules.conf in FC1 which has the
planetccrma stuff and thats ok as well now. I still get "Alsa driver
already started" on the boot-up on screen details for FC2, and when I
saw that thought it wasn't going to work properly again, but all was ok.
I had already made the additions when I got your e-mail Fernando, but
obviously if its worked ok on your laptop then both ways are ok to
resolve this issue.

alias snd-card-0 snd-emu10k1
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1
alias usb-controller uhci-hcd

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.7 ---
alias snd-card-0 snd-emu10k1
alias snd-card-1 snd-usb-audio    "THIS LINE ADDED"
alias sound-slot-0 snd-emu10k1
alias sound-slot-1 snd-card-1     "THIS LINE ADDED"
# --- END: Generated by ALSACONF, do not edit. ---

options snd-emu10k1 index=0       "THIS LINE ADDED"
options snd-usb-audio index=1     "THIS LINE ADDED"

It may be an idea to make an addition eventually to the part on the web
page "Configuring tha Alsa driver" with regard to using USB midi
keyboards. But I suppose you could go on forever allowing for all the
variables, and that section would become a manual in its own right.

Thanks again all you folks for the help. It Works!  Nigel.