[PlanetCCRMA] Re: ccrma vs at once again: libsndfile

Axel Thimm planetccrma@ccrma.Stanford.EDU
Mon Jan 3 17:28:01 2005

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Mon, Jan 03, 2005 at 04:34:39PM -0800, Brad Fuller wrote:
> This is getting quite frustrating..... I feel I should just start=20
> over..... :-(
> when trying to do some more upgrades for the latest ccrma FC2 kernel
> and packages, I came across my old friend that keeps biting my
> butt. Here's the latest incarnation (or, maybe it's an incantation):
> #apt-get install libsndfile
> file /usr/lib/libsndfile.so.1 from install of=20
> libsndfile-1.0.11-1.rhfc2.ccrma conflicts with file from package=20
> libsndfile1-1.0.10-5.rhfc2.at
> This time, I tried what I did before with the "libxslt" conflict
> (message a couple of days ago) -- namely, make the repository to
> ATrpms (at-stable) available in sources.list, install, and then
> comment ATrpms repository out again, then go on my merry way
> Unfortunately, this time, I get the same error.

Did you apt-get update? ATrpms has 1.0.11 since mid-November 2004, so
you are seeing old parts again.

> Perhaps I should just start over with a complete ccrma installation?
> If there is a better way, that'd be great. If not, is there anything
> special that I need to know about removing all audio libs? (I'd hate
> to do a complete re-installation of the OS!)

Perhaps you should activate ATrpms and have a full freshen up. The
idea of a repo is not to turn it on and off at different times. If you
are uncomfortable with the ATrpms repo you should not turn off the
repo before you kill all ATrpms packages.

Should you decide to go that way (I hope not), you can identify all
ATrpms packages with

rpm -qa --qf '%{vendor} %{name}\n' | grep ^ATrpms.net | awk '{print $2}'

If you want to get rid of these packages append an "| xargs rpm -e --nodeps"

And then have "apt-get -f install" cure the open wounds.

But I would recommend to let the repos active (along with others from
the medley-package-config) and have them do their job. ;=3D)
Axel.Thimm at ATrpms.net

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.6 (GNU/Linux)