[PlanetCCRMA] Hammerfall-DSP Multiface problems

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Tue May 29 14:06:54 PDT 2012

On 05/29/2012 11:13 AM, plutek wrote:
> greetings!
> it's been many years since i ran a PlanetCCRMA install -- i've been mostly on AVLinux in recent years. my Multiface is completely solid on AVL (which is 32-bit only) with their standard 3.0.6 kernel. since i got a new laptop (ThinkPad T520 with 6Gb of RAM, i've been interested in finding a 64-bit distro with a more recent kernel. i've tried various things (including 3.2 and 3.3 series kernels on AVL), with no success.
> so, i thought i'd give the Planet a try again,

Hey, welcome back!

>knowing that there's experience around CCRMA with HDSP boxes, and having 
read these posts by Fernando:
> -------------------------
> On 04/02/2012 03:52 PM, Fernando Lopez-Lezcano wrote:
>> Hi all, a new kernel based on 3.2.13-rt23 is available from the
>> planetcore-testing repository for Fedora 16... Only lightly tested on my
>> old laptop.
> The current kernel is now 3.2.16-rt27 based, the second revision I just
> published dropped a patch from previous Fedora kernels that was
> triggering "Disabling IRQ" problems, at least with my RME cards. Seems
> to work fine now.
> -------------------------
> my system details:
> T520 ThinkPad
> 6 Gb RAM
> i7 quad-core CPU @ 2.8GHz
> RME Hammerfall DSP Multiface on ExpressCard adapter
> PlanetCCRMA on FC16 (x86-64)
> my observations so far:
> kernel 3.1.0-7.fc16.x86-64 ----
> jack runs reliably down to 64x2
> hdspmixer runs reliably
> kernels 3.2.17-1.rt28.1.fc16.ccrma.x86-64.rt AND 3.3.7-1.fc16.x86-64
> jack starts, but locks up very quickly
> hdspmixer locks with error: "HwDep ioctl failed. Metering stopped"
> any help sorting this out would be most welcome... let me know if there are error messages or other console output which would be useful!

Hmmm, weird. Which version of alsa-tools do you have installed? (rpm -q 
alsa-tools to find out).

I'm running 3.2.17+ rt here at ccrma with RME hardware, but this is on 
old Fedora 14 i386 installs. I'm also running fc16 x86_64 + rt kernels 
on a test laptop (old Lenovo T61) I have and had no problems with jack 
using the built-in card.

-- Fernando

More information about the PlanetCCRMA mailing list