[PlanetCCRMA] jackdmp port limit problem

Hector Centeno hcengar at gmail.com
Tue May 19 21:42:07 PDT 2009

Thanks Orcan,

Starting Jack using --port-max didn't help either. I'm still
suspecting that the problem might be in jackdmp since, as I said, the
same project worked fine using the same version of Ardour (2.8) and
Qjackctl but with Jack 0.116 instead of 1.9.2. I'll try tomorrow to
look into jack's source code.



On Tue, May 19, 2009 at 11:49 PM, Orcan Ogetbil <oget.fedora at gmail.com> wrote:
> On Tue, May 19, 2009 at 11:21 PM, Hector Centeno wrote:
>> Hello,
>> I'm experiencing problems when trying to open an Ardour project that
>> contains over 100 tracks using Fedora 10 + CCRMA. This project used to
>> open fine under OpenSuse and using Jack 0.116 by changing the "Port
>> Maximum" setting in Qjackctl to 1024. I've tried doing the same thing
>> but I keep getting an error message from Ardour saying that I have to
>> increase the port number even though I increased the port maximum in
>> Qjackctl (and yes, restarted Jack). Also I get an error message in the
>> Messages window of Qjackctl saying: 'Maximum number of output ports is
>> reached for application ref = 4".
>> Is this due to differences in how the maximum port number is set in Jackdmp?
>> Thanks,
>> Hector
> Phew, 100 tracks...
> I never got past 15. You might want to start jack manually (using
> --port-max) and see if the problem persists. According to the result,
> you may need to contact qjackctl or ardour developers.
> We don't apply any patches to either application that might result in
> this behavior. You can have a look at our patches at
> http://cvs.fedora.redhat.com/viewvc/devel/ardour/
> http://cvs.fedora.redhat.com/viewvc/devel/qjackctl/
> Orcan
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

More information about the PlanetCCRMA mailing list