[PlanetCCRMA] Problems with Audiophile 2496

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Sat May 6 12:08:01 2006

On Sat, 2006-05-06 at 11:32 -0700, Brutus Gates wrote:
> I have a A8N5X mobo... (maybe it was a bad choice?)... with an athlon
> 64 3200+.
> I'm trying to install Fedora Core 4 on my computer. At one point
> towards the end of the installation, it asks you to test the
> soundcard. It recognizes both the onboard mobo "sound chip" as well as
> the Audiophile 2496 PCI card (ice-1712 driver). When I test the
> onboard mobo sound, it works for that test. When I test the audiophile
> 2496 it doesn't make a sound...
> Is this normal??? Do I need to do something simple after the
> installation process that will make it work?

It may be "normal", it depends on exactly what the installation test
program does. Most probably it does not know about the proper controls
that need to be tweaked to get sound out of it. All cards are different
and ALSA (the sound driver in Linux) does not yet have a completely
standarized interface as it reflects directly what the hardware can do. 

> The audiophile 2496 has two anolog outs that are hooked up to an amp.
> This setup worked fine when I boot Windows XP.
> I'm _really_ dissapointed that I'm having problems with Linux... ;(
> PS: what is up with FC4 anyway... the "onboard mobo" sound worked
> during the pre-installation test but it didn't work after the
> installation when I double clicked on a .wav file in usr/share/sounds.
> What the heck? All it does is make a faint high pitch buzzing noise
> instead of playing the .wav file... anyways... that's beside the point
> as I want my audiophile 2496 to work.

Oh well, Linux is very different from Windows. You'll have to arm
yourself with a little patience if you want to enter this new world.
Things are going to be different. Some things will not work. Others will
be fantastic, others frustrating. I guess it is part of the deal of
using something different, free (as in freedom) and "community created
and supported". 

Anyway, about the audiophile, it is a Midiman card so I would try to
start the "envy24control" application which comes with the alsa-tools
package. That one will show all controls that are specific for that
card. I don't have one so I don't know how things will look but I would
look at the "analog levels" (or something like that) tab. 

For the onboard soundcard you could use "gamix" or any other gui mixer
to look at the controls and change them. 

Then you have to use the right application to try to play your file. You
don't tell us what you want to do with fc4. The simplest demo app you
could use is a command line utility called "aplay", fire up a terminal
(right click on the desktop and select that option) and enter "aplay
whatever.wav", it should play your soundfile. If it does not check your
levels. As you have two soundcards you could be trying to play to the
wrong one (not the one you are listening to). If you are still in the
terminal you could type "cat /proc/asound/cards" to see the order of the
cards, the first number in the line will be the index of it. You could
say "aplay -D plughw:1" to point aplay at the second card if that's the
one you want. 

Good luck!
-- Fernando