[PlanetCCRMA] mysterious errors from ams "Could not find LADSPA plugin gverb from library gverb 1216"

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Fri Jun 30 12:09:02 2006

On Fri, 2006-06-30 at 07:23 -0400, Michael Tiemann wrote:
> I was playing around with ams on a long flight recently (no internet
> connection) and when I tried to load some of the presets I got error
> messages about plugins not being found.  Surprised, I did some googling
> and found this email message from 2004:
>   >>On Fri, 24 Sep 2004, Mark Wilson wrote:
>   >>When I try to load some of the demo or instrument patches, I get errors
>   >>saying "Could not find LADSPA plugins "Saw-VCO" from library
>   >>"vco_sawpulse" or "Could not find LADSPA plugin "G2reverb" from library
>   >>"g2reverb."  I am running version 1.7.7 which came with the Agnula DeMuDi
>   >>1.2.0 BETA distro.  When the pathces show up in the window, there are no
>   >>"cables" connecting anything. 
>   >>But when I load some patches, I see reverb modules, or at least I"m fairly
>   >>sure I"ve seen them.
>   >>
>   >>What am I doing wrong, if anything?
>   WWM> Not you, but the Agnula-Guys... Obviously they do not take much care that
>   WWM> AlsaModular works properly on their distro. And apparently they don"t
>   WWM> package the marvelous LADSPA plugins by Fons Adriaensen that are required
>   WWM> for AlsaModular. Fernando cares much more about these, but there are only
>   WWM> pa ckages for Fedora available:
>   WWM> http://ccrma.stanford.edu/planetccrma/software/
>   WWM> What you can do is compile the plugins yourself:
>   WWM> http://users.skynet.be/solaris/linuxaudio/
>   WWM> and let the Agnula-guys know that they miss something.
>   WWM> Oops, just checked the AlsaModular-Version that Agnula packages: It"s
>   WWM> centuries old !!! Better update to 1.8.7. BTW Fernando has already
>   WWM> packaged this version for Fedora ;-)
>   WWM> Greetings,
>   WWM>             Matthias
> Of note: specific kudos to Fernando for /not/ having these problems.

Well, thanks, but you _are_ having problems, right? :-)

> Also of note, I'm running the latest packages from PlanetCCRMA on FC5.
> Any thoughts on why I'm seeing these problems that are supposedly fixed?
> And finally--though the instrument appears to throw an error (and not
> connect up any cables specified in the ams file), there's a text message
> in my terminal window saying that gverb 1216 /was/ found and loaded.

Maybe there is something else missing other than freeverb?

> Can anybody running FC5
> load /usr/share/ams/instruments/example_presets.ams without seeing an
> error?

I can in my laptop's test fc5 install. Check /var/log/messages for error
messages. Some plugins (can't remember which collection, sorry) had a
problem with selinux which I worked around by going into the "Security
Level Configuration" panel, selecting the SELinux tab, then going to
"Compatibility" and clicking on "Allow the use pf shared libraries with
Text Relocation". Don't remember if I had to reboot. 

-- Fernando