[PlanetCCRMA] Rosegarden problem

Jamie Bullock jamie@postlude.co.uk
Wed Feb 16 02:50:02 2005

Dear Fernando,

I tried all of your suggestions, but to no avail. It was a good
excercise in clearing traces of fc2 from my system though! I've moved on
to trying to get the app to build from source. Using your 0.9 series
source packages I get a new error. I run:

./configure --with-qt-dir=/usr/lib/qt-3.3/ --with-qt-includes=/usr/lib/qt-3.3/include/ --with-qt-libraries=/usr/lib/qt-3.3/lib/

and configure fails at:

checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

I checked, and libqt-mt.so is definitely in qt-3.3/lib.

Any ideas?

BTW: have you tried building Rosegarden 1.0, I'd be interested to see if
you get the errror about libstd++-dev. I don't get this with the 0.9
config files.


On Tue, 2005-02-15 at 16:54 -0800, Fernando Lopez-Lezcano wrote:

> > Incidentally, I can't get Rosegarden to compile from source on my system
> > either. ./configure complains about a missing  libstd++-dev even though
> > I have the c++ compaibility libs...
> Have you tried to build from the source package? This is what I require
> for building the package, no compatibility libraries needed:
> BuildRequires: gcc-c++ ladspa-devel XFree86-devel
> BuildRequires: alsa-lib-devel curl-devel e2fsprogs-devel freetype-devel
> BuildRequires: glib2-devel glibc-devel jack-audio-connection-kit-devel
> BuildRequires: libart_lgpl-devel libmad-devel openssl-devel qt-devel
> zlib-devel
> BuildRequires: kdelibs-devel libpng-devel libtiff-devel libjpeg-devel
> BuildRequires: liblrdf-devel dssi-devel
> %if "%{fc2}" == "1" || "%{fc3}" == "1"
> BuildRequires: libselinux-devel
> %endif
> -- Fernando
Jamie Bullock <jamie@postlude.co.uk>