[PlanetCCRMA] Re: JACK isn't getting realtime (UPDATE)

Neil Klepeis nklepeis@sbcglobal.net
Mon Feb 14 13:44:01 2005

Hold everything!  I think I was confused about which kernel and 
playback/capture state I was using (parameters parameters everywhere!). 
  Now the RT stuff actually does seem to work.

I went back and tried everything again systematically with each FC3 
kernel and playback or capture mode on the Soundblaster AWE64 card 
(using ardour as the client).   Here's my results (RT=real time; NRT=no 
real time):

Stock FC3 kernel w/AWE64:
RT:not available
NRT:reasonably few xruns in playback OR capture mode

Stable LL FC3 planet kernel w/AWE64:
RT: no xruns in playback OR capture mode
NRT: some xruns, but usable, actually maybe more than the stock kernel

Edge rdt LL FC3 planet kernel w/AWE64:
RT: no xruns in playback OR capture mode
NRT: some xruns, but usable

Note:  To use capture w/AWE64, one _MUST_ mute the playback channels or 
ardour will suffer a hard death.   AWE64 can only playback at 8bit 
during capture mode, which JACK does not like.  AWE64 can definitely NOT 
be used in duplex mode.

Thanks for your help Fernando!


Neil Klepeis wrote:
> As I recall, the SB AW64 can do 16 bit capture OR playback, but can only 
> do 8bit playback during duplex operation (and so duplex mode probably 
> has no hope of working at all under JACK).
> I had already tried just starting JACK with 16-bit playback using 
> qjackctl on the SB AWE64, but there was no RT capability (w/ fresh and 
> pure FC3/planet install).
> Just now, I tried starting JACK by hand on the command line with: jackd 
> -R -dalsa -dhw:0 -r44100 -P ...but still no luck.  I get the same kind 
> of stuff:
> JACK: unable to mlock() port buffers: Cannot allocate memory
> jack_create_thread: error -1 switching current thread to rt for 
> inheritance: Unknown error 4294967295
> cannot start watchdog thread
> cannot load driver module alsa
> BUT, interestingly:  Starting _without_ RT capability seems OK (no 
> errors on startup and ardour can playback imported audio with no problem):
> jackd -dalsa -dhw:0 -r44100 -C
> OR
> jackd -dalsa -dhw:0 -r44100 -P
> But (as expected) duplex dies w/:
> jackd -dalsa -dhw:0 -r44100
> [...]
> Sorry. The audio interface "hw:0" doesn't support any of the hardware 
> sample formats that JACK's alsa-driver can use.
> ALSA: cannot configure capture channel
> cannot load driver module alsa
> Could it be that attempting to use RT in the kernel is interfering with 
> the alsa driver?    Since starting JACK w/o RT seems to actually work, 
> maybe I don't need RT for basic 2-channel stuff.  I don't seem to get 
> many xruns (yet).
> Hmmmm, I guess I'll also try my HDSP (currently on another machine) and 
> see if things for RT look up.