[PlanetCCRMA] Sound playback freezes system after updating kernel-modules-alsa

Nick Treleaven nick.treleaven@btinternet.com
Thu Apr 7 10:24:01 2005

I did an apt-get upgrade this afternoon, rebooted and tried playing back 
an .ogg in XMMS - my system hung, no response to ctrl-alt-del, had to 
reset. I've repeated this several times. I have ALSA as the XMMS output 
plugin and I suspect all ALSA playback will hang my system.
I'm running the 2.6.10-2.1.ll.rhfc3.ccrma FC3 kernel. I have a 
soundblaster Live (using EMU10K alsa driver) - this may be related to 
another post of today  "[PlanetCCRMA] Latest updates = total freeze" by 
Shayne O'Connor who also has an SB Live.

I guess one of these upgraded packages (probably alsa-driver or 
kernel-module-alsa) must be responsible:

-rwxr-xr-x  1 nmt nmt   305350 Apr  7 14:25 
-rwxr-xr-x  1 nmt nmt   301434 Apr  7 14:25 
-rwxr-xr-x  1 nmt nmt 14019454 Apr  7 14:25 
-rwxr-xr-x  1 nmt nmt     4598 Apr  7 14:25 
-rwxr-xr-x  1 nmt nmt     5972 Apr  7 14:25 

I've also tried restarting alsasound and watching dmesg but i get no 
message other than
PCI: Found IRQ 10 for device 0000:00:0f.0
*There seems to be nothing in the system logs about the hang either. Any 
Nick Treleaven
*P.S. I don't think this is related but just in case I sometimes [but 
not always and not when playback hung the system] get this message on 
alsasound start:
Restoring sound driver settings /usr/sbin/alsactl: set_control:930: 
warning: name mismatch (Mic Select/External Amplifier) for control #68
/usr/sbin/alsactl: set_control:932: warning: index mismatch (0/0) for 
control #68
/usr/sbin/alsactl: set_control:1030: bad control.68.value type