[PlanetCCRMA] Re: [linux-audio-user] planetedge kernels

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Wed Oct 13 08:55:02 2004

On Wed, 2004-10-13 at 08:35, Joey Reid wrote:
> On Oct 12, 2004, at 1:49 AM, Fernando Pablo Lopez-Lezcano wrote:
> > On Mon, 2004-10-11 at 18:23, Joey Reid wrote:
> >> Hi all. This is probably a question for Fernando, but I am not
> >> subscribed to the CCRMA list, so I will post it here and hope you will
> >> be kind.
> >
> > Hmm, maybe you should have subscribed then, this is a very specific
> > question... :-)
> OK, I will move this here, since I still can't get this to work.
> I am trying to boot the planetedge kernel, and I am not 
> having much luck. The kernel is unable to mount the root filesystem on 
> my SATA disk. It gives an error like the following:
> "VFS: Cannot open root device "LABEL=/" on unknown-block(0,0)
> Please append a correct "root=" boot option
> Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)"

What are messages right before this? Just to get a handle of where in
the boot process you are at that point. 

> I posted this problem on linux-audio, and Fernando you suggested that 
> the "root=" option would need to contain the scsi device name, since 
> the newer kernel uses libata and therefore scsi to access SATA disks. 
> Since my disk under 2.6.5 is called "/dev/hdc5" I tried 
> "root=/dev/sdc5", but that did not work. I then tried guessing at the 
> scsi disk number. It would not work with sda5, sdb5, sdc5, sdd5, or 
> sde5 ;-)

Hmmm... what I would have done, I guess. partition "5" is /boot? "5" as
the number sounds strange, is this an extended partition? What is
partitioning of the disk like? (fdisk -l /dev/hda when booted in the
kernel that works). 

> I don't know if this matters, but my root partition is using XFS (/boot 
> is ext3). I know it might matter in that it may not allow using 
> "LABEL=" (according to some info that google returned), but other than 
> that I'm not sure it should matter. I do see the XFS driver loading 
> immediately before it gives me the above error, so I know that it must 
> be included in the initrd.
> soooo, any other ideas?

I know the messages probably scroll too fast, but do you see anything
related to sdx while the boot is progressing? (just in case, turn off
the graphical boot by editing the grub kernel boot command line and
erasing the "rhgb -etc-" part). 

I have never tried xfs so I don't know if that may be the problem.
Changing fstab to ommit the label could be an option but first make sure
that you can boot into rescue mode with a cd and revert it (if the boot
fails). But you have to find out what is the device name first (what is
x in sdx). 

-- Fernando