[PlanetCCRMA] Re: [linux-audio-user] planetedge kernels

Joey Reid joe@joeyreid.com
Wed Oct 13 08:37:00 2004

On Oct 12, 2004, at 1:49 AM, Fernando Pablo Lopez-Lezcano wrote:

> On Mon, 2004-10-11 at 18:23, Joey Reid wrote:
>> Hi all. This is probably a question for Fernando, but I am not
>> subscribed to the CCRMA list, so I will post it here and hope you will
>> be kind.
> Hmm, maybe you should have subscribed then, this is a very specific
> question... :-)

OK, I will move this here, since I still can't get this to work.

I am trying to boot the planetedge kernel, and I am not 
having much luck. The kernel is unable to mount the root filesystem on 
my SATA disk. It gives an error like the following:

"VFS: Cannot open root device "LABEL=/" on unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)"

I posted this problem on linux-audio, and Fernando you suggested that 
the "root=" option would need to contain the scsi device name, since 
the newer kernel uses libata and therefore scsi to access SATA disks. 
Since my disk under 2.6.5 is called "/dev/hdc5" I tried 
"root=/dev/sdc5", but that did not work. I then tried guessing at the 
scsi disk number. It would not work with sda5, sdb5, sdc5, sdd5, or 
sde5 ;-)

I don't know if this matters, but my root partition is using XFS (/boot 
is ext3). I know it might matter in that it may not allow using 
"LABEL=" (according to some info that google returned), but other than 
that I'm not sure it should matter. I do see the XFS driver loading 
immediately before it gives me the above error, so I know that it must 
be included in the initrd.

soooo, any other ideas?
Joey Reid aka Dr.Whiz-Bang
Geek, musician, and friend of God