[PlanetCCRMA] Re: 2.6.7 ccrma kernel and usb / nvidia support

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Fri Nov 19 17:12:01 2004

On Fri, 2004-11-19 at 16:21, Shayne O'Connor wrote:
> On Sat, 2004-11-20 at 07:36, Rick B wrote:
> >      I was waiting for Fernando to give his expertise on this but since 
> > he's no doubt very busy I'll go ahead and add my 2 cents worth. On 
> > /proc/bus/usb/devices you only have read permission and this *might* be 
> > a problem, but I don't have any expierience troubleshooting this kind of 
> > problem, so I can't say for sure. Have you tried doing this as root? If 
> > it works as root then it is a permissions problem. By the way, you have 
> > a lot of stuff starting at boot that you really don't need 
> > (sendmail,portmap,netfs,etc...).
> well, it's working again ?! i had reinstalled the system again (more to
> just get it clean after lots of messing around) and then tried gnomad2
> again - but nope, wasn't working ... still worked in the 2.6.5 kernel.
> then, after reading your post, i did some looking around, and changed
> permissions on /etc/hotplug/usb/nomad.usermap from 644 to 755. then i
> plugged in my creative zen touch, and - it scanned the songs, and worked
> as it should?! just to check, i changed the permissions back to 644, but
> it still worked! does this mean that whatever i did to nomad.usermap
> wasn't what fixed it?

No, I think what you did fixed it. You changed nomad.usermap's
permissions so that the program could write to it. Obviously the first
time you run the program something got added (you would have gotten the
same behavior if you had run it as root the first time - not that I
would recommend you do that, of course). Once the file got "updated"
then permissions don't matter, it will just work... If you have the
original file you could diff it to see what changed...

-- Fernando