[PlanetCCRMA] no recording sound on fc1

Carl Bolstad Carl Bolstad <carl.bolstad@gmail.com>
Fri Nov 12 23:16:01 2004

Hello List!

I am a newbie Linux user (since about a year ago), and a few months
ago I downloaded the Planet CCRMA fc1 disks and installed the system
from scratch. I printed out the ccrma install instruction pages and
kept notes on what I did. So far, I have been unable to get any of the
audio applications to work, however. They install OK, and they seem to
run, but I can't get any sound into them. For instance, I was trying
to record from a stereo tape player into Ardour, but I can't get
Ardour to register any sound coming in. I checked the output from the
tape with headphones, and it seems ok.

It took me a while to get jack to start. I had to run the ALSA
soundcard detection script several times; each time it seemed to work,
but there were always modules missing or something, and there was no
sound. Now I've succeeded in getting some sound on my system, and jack
will start, though I'm still not sure it's doing what it should. I
just know that Ardour will start up, now.

Here's the latest output from starting jack:

[~/Sound Files]$ cat jack.messages
back from read, ret = 1 errno == Success
jackd 0.99.0
Copyright 2001-2003 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

loading driver ..
apparent rate = 44099
creating alsa driver ... hw|hw|1024|2|44099|0|0|nomon|swmeter|-|32bit
configuring for 44099Hz, period = 1024 frames, buffer = 2 periods
Couldn't open hw for 32bit samples trying 24bit instead
Couldn't open hw for 24bit samples trying 16bit instead
Couldn't open hw for 32bit samples trying 24bit instead
Couldn't open hw for 24bit samples trying 16bit instead
jackd watchdog: timeout - killing jackd
[~/Sound Files]$


I know 44099 Hz is kind of weird, but it used to give me an error
message about 44100 Hz not matching 44099 Hz, so I thought I would try
requesting 44099 in the first place (since nothing was working

The root of the problem may in fact be with the ALSA drivers, because
whenever I boot up the system, I get error messages like the following
emailed to root:


--------------------- Kernel Begin ------------------------

WARNING:  Kernel Errors Present
    I/O error: dev 08:00, sect...:  5Time(s)
    sda: I/O error: dev 08:00, sect...:  5Time(s)
   microcode: Error in the microcode...:  1Time(s)
   microcode: error! Bad data in mic...:  1Time(s)

 ---------------------- Kernel End -------------------------

 --------------------- ModProbe Begin ------------------------

Can't locate these modules:
   sound-service-1-0: 4 Time(s)
   snd-seq-client-62: 1 Time(s)
   sound-slot-1: 4 Time(s)
   char-major-188: 2 Time(s)

 ---------------------- ModProbe End -------------------------


Seems like there were a few times when only the 'snd-seq-client-62'
line was not located, but of course, still no sound applications
worked. Usually, the system has sound in general - it does a harp-type
sound when I open an application, and a zip-bang thing when one
closes. Although yesterday it was totally silent, and the soundcard
detection app (under system settings) said that no soundcard was
detected. Today there is sound, but I'm having more and more problems
with the machine completely freezing up. I had to boot three times
today because the first two froze. The second time, it froze up just
as the "startup sound" started when I logged in.

I just recently installed the Audacity sound editor, and I think it's
all I would need, if I could get it to work (I just want to be able to
cut unwanted parts from recordings, really). It starts up just fine,
but it doesn't register any sound input, either.

Here are the latest Audacity messages, last time I tried it, after
failing with jack and Ardour:

[~/Sound Files]$ audacity
PortAudio: read interrupted!
PortAudio: read interrupted!
[~/Sound Files]$

[~/Sound Files]$ cat ardour.messages
Loading UI configuration file /etc/ardour/ardour_ui.rc
Signal 2 received
[~/Sound Files]$


So I don't know if it's the kernel modules, or jack, or the sound card
(Ensoniq AudioPCI ENS1371), or me not really knowing what I'm doing!

Here's more stuff:

[~/Sound Files]$ cat /proc/asound/cards
0 [AudioPCI       ]: ENS1371 - Ensoniq AudioPCI
                     Ensoniq AudioPCI ENS1371 at 0xdcc0, irq 9
[~/Sound Files]$

[~/Sound Files]$ lsmod
Module                  Size  Used by    Not tainted
snd-pcm-oss            45160   0 (autoclean)
snd-mixer-oss          16728   0 (autoclean) [snd-pcm-oss]
binfmt_misc             7816   1
snd-seq-midi            5152   0 (unused)
snd-seq-midi-event      6272   0 [snd-seq-midi]
snd-seq                49744   0 [snd-seq-midi snd-seq-midi-event]
snd-ens1371            17540   1
snd-pcm                85984   1 [snd-pcm-oss snd-ens1371]
snd-timer              20996   0 [snd-seq snd-pcm]
snd-page-alloc          9304   0 [snd-pcm]
snd-rawmidi            19520   0 [snd-seq-midi snd-ens1371]
snd-seq-device          6220   0 [snd-seq-midi snd-seq snd-rawmidi]
gameport                3380   0 [snd-ens1371]
snd-ac97-codec         63464   0 [snd-ens1371]
snd                    48708   0 [snd-pcm-oss snd-mixer-oss
snd-seq-midi snd-seq-midi-event snd-seq snd-ens1371 snd-pcm snd-timer
snd-rawmidi snd-seq-device snd-ac97-codec]
soundcore               6660   6 [snd]
parport_pc             19172   1 (autoclean)
lp                      9060   0 (autoclean)
parport                37792   1 (autoclean) [parport_pc lp]
autofs                 13748   0 (autoclean) (unused)
3c59x                  30032   1
ipt_state               1048   2 (autoclean)
iptable_filter          2444   1 (autoclean)
iptable_nat            23000   0 (autoclean) (unused)
ip_conntrack           31560   0 (autoclean) [ipt_state iptable_nat]
ip_tables              15872   5 [ipt_state iptable_filter iptable_nat]
sr_mod                 18168   0 (autoclean)
microcode               5956   0 (autoclean)
ide-scsi               12240   0
ide-cd                 36128   0
cdrom                  34048   0 [sr_mod ide-cd]
nls_iso8859-1           3516   2 (autoclean)
nls_cp437               5148   2 (autoclean)
vfat                   13228   2 (autoclean)
fat                    40312   0 (autoclean) [vfat]
sg                     37772   0 (autoclean)
sd_mod                 13420   0 (autoclean)
usb-storage            77024   0
scsi_mod              109944   5 [sr_mod ide-scsi sg sd_mod usb-storage]
keybdev                 3136   0 (unused)
mousedev                5620   1
hid                    24996   0 (unused)
input                   5856   0 [keybdev mousedev hid]
usb-uhci               27372   0 (unused)
usbcore                81408   1 [usb-storage hid usb-uhci]
ext3                   74052   2
jbd                    54548   2 [ext3]
[~/Sound Files]$


I'm sorry if this email has gotten a little long and ramble-y. Anyone
know what I need to do to record sounds?


Carl Bolstad