[PlanetCCRMA] terminatorX and liblrdf

Joe Hartley jh@brainiac.com
Mon Mar 15 03:45:02 2004

On 14 Mar 2004 11:17:59 -0800
Fernando Pablo Lopez-Lezcano <nando@ccrma.Stanford.EDU> wrote:
> > after some PlanetCCRMA upgrades on Fedora I tried to use terminatorX 
> > (worked fine before) and got an errormessage:
> > something like cannot locate "liblrdf.so.0"
> > i made a link to liblrdf.so.2 in /usr/lib
> > and it worked fine again, 

Fernando, I ran into this recently too - my most recent build of Ardour
for the first time failed, wanting liblrdf.so.0.  linked to 
/usr/lib/liblrdf.so and all was well, but this was the first time I've seen
this.  Aside from Ardour, I install everything on this system using 
Synaptic to fetch the upgrades from the Planet's repositories.

There were no files of the format /usr/lib/liblrdf.so.n on my system.

> What does "apt-get check" say? You should have broken dependencies, I
> think. 

I've got no broken dependencies, and my liblrdf's are at:

> You don't need, and should not have, the link you made in /usr/lib (to
> the .so.0 library). You need the proper terminatorX that is linked
> against the latest liblrdf. 

Perhaps I should be asking the Ardour developers about this, but it seemed
too coincidental to me, so I thought I'd mention it.

       Joe Hartley - UNIX/network Consultant - jh@brainiac.com
Without deviation from the norm, "progress" is not possible. - FZappa