[PlanetCCRMA] No sound from SB Live!

Jesse Kaufman glandix@lloydnet.org
Tue Jun 15 09:33:01 2004

On Tuesday 15 June 2004 10:52 am, Tom Olson wrote:
> options  -k snd-card-0
> ===========================================================
> I added the last line, per the Install guide. I rebooted using the new
> modules.conf file, but still no sound. I checked what modules were
> loaded with lsmod:
>  ==========================================================

dunno if this last line is actually necessary or not (i've been using my 
SBLive! Value for my HTPC w/o a hitch and i don't have that line), but 
otherwise your modules.conf is exactly the same as mine (at least for the 
alsa stuff)

> It looks like the right modules are loaded, did nor see a emu10k1
> module, so that looked fine to me. I checked the mixer with alsamixer,
> levels were fine and not muted.

hmm, that is strange ... what are you using to test for sound?  play?  xmms?

> I was looking around the archives and thought it must be something with
> the "modules.conf" file. I went to the Alsa website, looked up the SB
> Live! in the card matrix, did not see anything "really" wrong.

correct, your modules.conf looks great to me ... i am running slack-current on 
the system w/ the SBLive! but i've used MDK and FC1 w/o a hitch ...

> Finally, out of frustration, I decided to try again, this time with
> Agnula on top of Fedora 1.
> Reloaded Fedora 1,  installed Agnula, and this time the SB Live! works.

odd ... it's been a while since i've used FC1, but one thing i've noticed on 
my HTPC here is that occasionally i have to "restart" alsa using the init 
scripts (in slack i run 'sh /etc/rc.d/rc.alsa restart' so i'm guessing you'd 
run 'service alsa restart' in FC1) to get sound (in my case it seems that 
xine leaves the sound card in AC3 pass-through mode and restarting fixes 
that) ...

> options snd major=116 cards_limit=1

not 100% sure what this line does, other than limit the number of cards it 
tries to initialize/configure to 1 and probably just reiterates the "alias 
char-major-116 snd" line, but don't quote me on that ...

> options snd-emu10k1 index=0

i believe this just tells alsa that the SBLive! is sound-card-0 (if you have 
more cards, you'll get sound-card-1, sound-card-2, etc)

> Still no sound....

just to make sure i'm following, you took the modules.conf you got from the 
agnula setup and copied it onto a FC1 install?

> Is it "kudzu" in Agnula that made the difference? Any suggestions on how
> to troubleshoot?

what version of alsa are you using?  ('rpm -qa | grep alsa') ... again, what 
are you using to test sound?  i assume (since you mentioned it previously) 
that on this last try you remembered to unmute all the channels ...  anything 
interesting in /var/log/messages?  any output if you run 'service alsa 

> Is this actually a question for the Alsa guys?

might be if no one else has any ideas ... i apologize for my rusty knowledge 
of FC1, since all my boxes are running slack-current (which is kinda ironic 
since i'm on a mailing list for an project that's entirely RPM-based :P ... 
would love to see planet-ccrma for slack *hint, hint* ... would be willing to 
help w/ packages if anyone would be interested) ...

also, the last time i had problems w/ my SBLive, i noticed that the 
documentation on the ALSA website seemed to be a bit out of date or at the 
very least difficult to follow .... judging by your first copy of your 
modules.conf you ran the alsaconf utility to setup your card ... if not, you 
might try this again (i believe you'll have to shutdown alsa for it to work 
properly) ...  the only other thing i can think of is that on some distros i 
had problems getting the mixer to work correctly as a non-root user and fixed 
that by chmod'ing the sound-related device files to 666 (rw by user, group 
and other) ... i believe they can be found in /dev/snd or at the very 
least /dev/dsp0 and /dev/mixer0 ...

if you do feel that this is too "off topic" for the ccrma list, feel free to 
e-mail me privately and i'll help any way i can! :)