[PlanetCCRMA] root vs capabilities

R Parker rtp405@yahoo.com
Tue Jun 1 11:01:01 2004

Hi Mark,

--- Mark Knecht <mknecht@controlnet.com> wrote:
> Fernando Pablo Lopez-Lezcano wrote:
> >>I suppose there could be something to the switch
> from
> >>Gentoo to CCRMA but wouldn't the issues be centric
> to
> >>the kernel and not the distribution?
> > 
> > 
> > They _should_ be, of course. Maybe Gentoo has some
> patches that I don't?
> > I don't think so, but it is always a possibility -
> I am assuming you are
> > using the same or similar release (2.4.26 is the
> current in Planet
> > CCRMA). It could also be the change in the video
> card. 
> I think there are non-audio patches Gentoo applies
> that CCRMA probably 
> doesn't have, but this is all hearsay.
> I run Gentoo very successfully without the
> capabilities patch on a 2.6.6 
> kernel. I don't have many problems with xruns but I
> no longer push 
> latency at all and only use Jack for LinuxSampler
> and sometimes alsaplayer.
> Maybe Ron should/could try a Vanilla kernel, or a
> Gentoo kernel itself? 
> Do an emerge on a Gentoo box and then drag the tree
> over to the RH 
> machine and try building it?

With Gentoo, I was using vanilla kernels and patching
them with LL, Love and capability.

I have to suspect this Radeon 9500 card as being the
most likely culprit.

There is another issue. I used to run this hardware
setup with dual processors. I stopped doing this
because there seems to be a bios bug that causes a
conflict between the 66mhz pci bus and dual CPUs. By
removing one CPU it eliminates an IRQ conflict between
the CPUs that caused ceasures during the bios stage of
the boot and lockups if I could get through a boot. I
never tried to force 33mhz on the bus.

Even with one CPU I've never noticed the total
percentage of use as being problematic. I guess this
is something else to watch a little closer.

Oh, the reason for me to want the 66mhz but is because
my raid controler can take advantage.

Is latencytest part of CCRMA? I tried compiling that
from tar but get the "can't stat *.png" messages. If I
recall that was the libld. Maybe there's an issue with


> - Mark

Do you Yahoo!?
Friends.  Fun.  Try the all-new Yahoo! Messenger.