[PlanetCCRMA] Problems with the new kernel SOLVED

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Sat Sep 27 11:58:02 2003

> I'm writing this running the new kernel. Everything seems to work fine,
> haven't started testing the audio equipment, but that is not the issue
> here. The issue is, or was, the kernel not booting due to the root fs
> being mounted read-write instead of read-only for fsck operation.
> I unpacked the initrd image, mounted it and checked the linuxrc and
> found the line mounting the root fs:
>   mount -o rw --ro -t ext2 /dev/root /sysroot
> Something veeery fishy about this line, so I changed it to
>   mount -o ro -t ext2 /dev/root /sysroot
> Umounted, gzipped and copied the new image to /boot/ and voilá!
> I tested mounting a fs with the --ro parameter, which I've never seen
> before in my life and it really worked, it really mounted the fs. 

Meaning it mounted "ro" even though it has a "-o rw" as well?

> Now what I can't figure out is why didn't it mount the fs read-only for me
> and why it mounts read-only for everyone else?

What version of mkinitrd do you have? On RedHat 9 I get 
mkinitrd-3.4.42-1. Version of mount? (mount-2.11y-9) I would imagine it
could be a problem with mkinitrd (seems to be adding a "rw" parameter to
the mount line) or mount (does not behave as expected - but it _does_
when you execute it outside of the mkinitrd script?). Very weird. 

I'll see if I can check what I have in my redhat 9 systems...

> But, anyways. Everything seems to be in order and I have a kick-ass
> kernel and ready to do some recording!
> Thanks for your great work on these packages Fernando!

Sure! Glad the system is up and running...
-- Fernando