[PlanetCCRMA] ALSA configuration problem

Juha Rouhiainen juha.rouhiainen@welho.com
Wed Jan 15 13:32:01 2003

Yes. It's a long story and I might not remember all things correctly.
First I downloaded ALSA-sources from www.alsa-project.org.
However I could not get ALSA operational. Propably it was something with
incorrect module versions (unresolved symbols in snd-xxx.o).
The reason behind the errors could be insufficient cleaning after kernel
module updates for NTFS-support, which happened earlier. I did not
understand it then.
Propably I upgraded RedHat from 7.3 to 8.0 at that time.

Then I discovered Planet CCRMA and downloaded RH8.0 binaries for ALSA.
I also downloaded source because I needed NTFS-support (the other OS in my
machine is Xp Home). When I built kernel from source I entered troubles with
gcc version. So after several tries I decided not to try to build
NTFS-support for 2.4.19-1.ll.

So I deleted (or at least tried to delete) all the ALSA & kernel source code
and also object code. If I remember it correctly I run 'make uninstall' in
source directory.

I reinstalled ALSA binaries from Planet CCRMA (apt-get install alsa-xxx
I reinstalled kernel binaries from Planet CCRMA (apt-get install
kernel-up#2.4.19-1-1.ll --reinstall).

Now I have kernel 2.4.18-14 with ALSA support and NTFS support, but I still
get other music software playing any midi-sounds. I tried Rosegarden and
some other midi-playing software without any sounds coming out.

Now it seems that everything is so mixed up, that it might be better to
install RH8.0
again from scratch and give Planet CCRMA a second try from clean base.

Yes all audio channels are unmuted (alsamixer) in both cases.

-- Juha
-----Alkuperäinen viesti-----
Lähettäjä: planetccrma-admin@ccrma.Stanford.EDU
[mailto:planetccrma-admin@ccrma.Stanford.EDU] Puolesta Fernando Pablo
Lähetetty: 14. tammikuuta 2003 5:06
Vastaanottaja: Juha Rouhiainen
Kopio: planetccrma@ccrma.Stanford.EDU
Aihe: Re: [PlanetCCRMA] ALSA configuration problem

> However I run into troubles with ALSA configuration.
> I have configured ALSA using alsaconf.
> My distribution is RH8.0 and my sound card is SB 128 PCI (ens1371.o).
> If I boot with kernel 2.4.18-14 command 'aplay --verbose test.wav' works
> However when I boot with kernel 2.4.19-1.ll same command 'aplay --verbose
> test.wav' does not produce any sound. No error messages, just silence.

That is very strange. Planet CCRMA does not include binary drivers for
kernel 2.4.18 so I don't see how alsa could be working under 2.4.18. You
must have rebuilt and alsa-driver source rpm and installed the kernel
modules, right?

I assume that alsamixer (or gamix) shows the audio channels unmuted and
with non-zero volume in both cases?

-- Fernando

PlanetCCRMA mailing list