[PlanetCCRMA] problems installing asla

Harrison Thomas harrisonfthomasjr@attbi.com
Wed Jan 8 11:46:01 2003

Hi Fernando

Thanks for the quick reply. I ran the two rpm queries-> the kernel query
returned i386 but the alsa-driver query returned i686! I have no idea how
the i686 driver got installed, since I removed the alsa packages and
reinstalled. It was probably already there. Oh well. I just went to system
logs and looked at installed rpm packages - it lists both
alsa-driver-0.9.0-43.1.i386.rpm AND
asla-driver-2.4.19-1.ll-0.9.0-43.1.i686.rpm!! Synaptic just lists the
"alsa-driver-2.4.19-1.ll", no i386 or i686. How do I remove just the i686
driver? If I remove the alsa-driver-2.4.19-1.ll with Synaptic, will that
remove the i686 driver also? Then just reinstall the i386 driver? Or remove
all alsa packages and reinstall (altho that's what I did just before
emailing the list and the i686 driver is still there.)
Yes, the new kernel boots just fine, I've turned the low latency patch on,
modules.conf was written to succesfully by alsaconf (no snd- except sound
card)and matches the listing on the PlanetCCRMA site, except for sound-card

Again thanks for the help


-----Original Message-----
From: Fernando Pablo Lopez-Lezcano [mailto:nando@ccrma.Stanford.EDU]
Sent: Tuesday, January 07, 2003 11:36 PM
To: Harrison Thomas
Cc: planetccrma@ccrma.Stanford.EDU
Subject: Re: [PlanetCCRMA] problems installing asla

> What are all those unresolved symbols?

For some reason the kernel does not match the drivers. I assume you have
successfully rebooted into the new kernel, right? I do have a machine
with the i386 kernel and drivers installed, let's see if the architectures
for the rpms in your case match, in a terminal do:

# rpm -q --queryformat  "%{ARCH}\n" kernel-up-2.4.19-1.ll
# rpm -q --queryformat  "%{ARCH}\n" alsa-driver-2.4.19-1.ll

Both should be i386 in your case.
And this should be the version number of the driver itself:

# rpm -q alsa-driver-2.4.19-1.ll

If both match then there is something wrong with the rpm in the site. I had
a problem a while ago but I (supposedly) fixed it.

> The first two entries: "Can't locate module sound-slot-0" and "Can't
> module sound-service-0-3" - are these remnants of the  OSS install that
> removed ? Or not?

Probably not, the reason is that alsa has not started, I think. What is
the content of /etc/modules.conf?

-- Fernando