[PlanetCCRMA] The 'Planetary' Kernel

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Thu Feb 27 18:51:02 2003

> Now for a couple questions. I first tried the 2.4.19 acpi kernel and got
> a kernel panic when booting. It didn't surprise me as everything else I
> had tried failed so this came as no surprise to me. However, I've been
> hell bent on getting sound going on this laptop and didn't give up. Ran
> into a thread in the archives where you pointed a fellow list member to
> the kernel-up-2.4.20-1.12.ll.acpi.i686.rpm. What the hell, I'll give it
> a go. It was late and I'm afraid that I woke up the kids when KDE
> started up and played a tune upon boot. My wha-hoo's probably
> contributed a bunch to the fact that my kids woke up, but after so many
> months of struggle I couldn't contain my excitement. I knew I needed
> acpi support, but for whatever reason I could never get a kernel to
> patch, I always got errors during the patch process. Now I start looking
> around for this kernel and it took me awhile to figure out that it lives
> in the /lib/modules directory. 

That's where the compiled kernel modules live (under subdirectories
named after the kernel version). The kernel proper is installed in /boot
and it's named something like vmlinuz-VERSION. 

> I found that rather odd, however I didn't
> question it as I got TUNES baby ! So now I'm curious, why does it live
> there rather than in /usr/src ? 

/usr/src/linux-VERSION is the source code for the kernel, not the kernel
itself. It is sometimes necessary to install the kernel-source code if
you want to build additional kernel modules (and it is packaged in the
kernel-source rpm). 

> Also, I have (by RedHat upgrade defaults), 4 other kernels I can boot,
> besides the one you have provided, making 5 total. So I'd like to get
> rid of at least 3 of these kernels. What would be the proper way to rid
> the system of these kernels without breaking everything ?

Find out what version you want to get rid off (for example 2.6.23 :-).
Then do a:
  rpm -q -a | grep kernel | grep 2.6.23
That will list all rpms that are hopefully related to that kernel. You
can use "rpm -e" to erase them. I would leave the original redhat kernel
that was installed when you installed redhat, and the latest redhat
upgrade (and the planet ccrma kernel that works). The rpm -e process
will not erase (I think) the entries that you see in grub, for that you
have to (carefully) edit /boot/grub/grub.conf. Make sure that you make
the default zero based index point to the kernel you want to boot by
default after you erase the entries you don't need. 

> One more question, I thought I'd give the
> alsa-driver-2.4.20-1.12.ll.acpi-0.9.0-44.i686.rpm a go and downloaded
> and installed it. I went through your tutorial on how to install this
> package only to find at the end that the package is missing one major
> component, the start script which is supposed to live in the
> /etc/rc.d/init.d/ directory. 

(BTW, the current release is "-45") The alsasound startup script lives
in the alsa-driver-0.9.0-45.i386.rpm rpm. You have to install that (and
the corresponding alsa-lib, alsa-utils and alsa-tools packages) to get
all of the alsa software that is needed. Read the instructions in the
web site on how to install and configure alsa for more details. The
alsa-driver, alsa-lib, alsa-utils and alsa-tools you can install using
apt-get _after_ you manually install the alsa-driver-2.4.20-1.12.ll.acpi
rpm you downloaded (that is because it is still outside of the apt-get

> whole works. Try that billy ! Anyhow, I just did an rpm -e and got rid
> of the package and am happy as hell with what I have for now. So did I
> download the wrong package, or was this package broke ? 

Neither. If you erased the alsa driver rpm and sound is working you are
using the oss drivers that are included in the kernel. You need to
install the full set of alsa packages _and_ configure them before you
can get sound through alsa. 

> I tried the
> install twice with the same results by the way. A little more info about
> this is, as of now I have nothing at all installed that pertains to
> alsa. Not one package do I have that has alsa in it, not the base files
> or anything. So I can start clean when it comes to installing alsa. What
> packages would you suggest that I grab and will alsa be a much
> richer/functional sound driver than what I have now ?

It depends on what software you want to use. Most of the software in
Planet CCRMA requires the alsa drivers...

> By the way, you are absolutely the best at writing howto's , readme's,
> tutorials or whatever you prefer to call them Fernando. Absolutely the
> best, hands down. You are without a doubt a breath of fresh air and a
> major asset to the whole Linux community. I wish you well in all your
> endeavors.

-- Fernando