[PlanetCCRMA] The 'Planetary' Kernel

Bryan Parrish baparrish@starband.net
Thu Feb 27 17:38:01 2003

What a fantastic resource ! First of all a big thank you to you Nando.
For the first time in 8 months I can finally listen to music on my
laptop. Been beating my head against the wall on this issue for months. 

Here is the setup that I am running right now. It's a ProStar laptop
model 6194 (by Clevo ?). It's a P4 2.2Ghz/512 DDR shared memory with the
video and the SiS650 chipset which uses the SiS7012 PCI Audio
Accelerator (which will run as/with the i810_audio module). I'm running
RedHat 8.0 on it with the default kernels supplied by RedHat, the last
one being the 2.4.18-24.8.0 kernel. I've gone through countless
upgrades, reinstalls, bad advice, flames, you name it. I've made all the
mistakes. The upside of that is the knowledge gained, therefore nothing
lost. Then I found this joint. Thank you all !

Now for a couple questions. I first tried the 2.4.19 acpi kernel and got
a kernel panic when booting. It didn't surprise me as everything else I
had tried failed so this came as no surprise to me. However, I've been
hell bent on getting sound going on this laptop and didn't give up. Ran
into a thread in the archives where you pointed a fellow list member to
the kernel-up-2.4.20-1.12.ll.acpi.i686.rpm. What the hell, I'll give it
a go. It was late and I'm afraid that I woke up the kids when KDE
started up and played a tune upon boot. My wha-hoo's probably
contributed a bunch to the fact that my kids woke up, but after so many
months of struggle I couldn't contain my excitement. I knew I needed
acpi support, but for whatever reason I could never get a kernel to
patch, I always got errors during the patch process. Now I start looking
around for this kernel and it took me awhile to figure out that it lives
in the /lib/modules directory. I found that rather odd, however I didn't
question it as I got TUNES baby ! So now I'm curious, why does it live
there rather than in /usr/src ? 

Also, I have (by RedHat upgrade defaults), 4 other kernels I can boot,
besides the one you have provided, making 5 total. So I'd like to get
rid of at least 3 of these kernels. What would be the proper way to rid
the system of these kernels without breaking everything ?

One more question, I thought I'd give the
alsa-driver-2.4.20-1.12.ll.acpi-0.9.0-44.i686.rpm a go and downloaded
and installed it. I went through your tutorial on how to install this
package only to find at the end that the package is missing one major
component, the start script which is supposed to live in the
/etc/rc.d/init.d/ directory. I believe I read another thread relaying
the same thing. This broke the sound that I had, but after renaming a
couple files I had sound back. This is one of the coolest things about
Linux, it might be broke, but renaming a file here and there fixes the
whole works. Try that billy ! Anyhow, I just did an rpm -e and got rid
of the package and am happy as hell with what I have for now. So did I
download the wrong package, or was this package broke ? I tried the
install twice with the same results by the way. A little more info about
this is, as of now I have nothing at all installed that pertains to
alsa. Not one package do I have that has alsa in it, not the base files
or anything. So I can start clean when it comes to installing alsa. What
packages would you suggest that I grab and will alsa be a much
richer/functional sound driver than what I have now ?

By the way, you are absolutely the best at writing howto's , readme's,
tutorials or whatever you prefer to call them Fernando. Absolutely the
best, hands down. You are without a doubt a breath of fresh air and a
major asset to the whole Linux community. I wish you well in all your