[PlanetCCRMA] my observations with installing CCRMA at Home

Alex Timmer mijn_troep@yahoo.com
Wed Apr 9 05:41:02 2003

hello again

i would like to give some feedback after i installed planet 'karma'
at home. i used the CDROM ISO's as the machine i installed has no
internet connection. 

first some cold facts (donno if useful):
Athlon 1GHz/133FSB
nVidia geforce 2MX
dusty SBLive
48/16DVD-ROM (16 speed dvdrom)
ATA100 7200rpm 40GB hdd

in the chapter "Installing the kernel and sound drivers", alsaconf
did not recognize my SBLive! WTH?! (i never used alsaconf before). i
tried creating my own /etc/modules.conf file out of a mix of the one
on the ALSA website and the one that Fernando presented for the
ens1370 based card. this was not successful, so i tried running
alsaconf again. i did something that made it "rebuild soundcard
database..." and voila, alsaconf recognized my SBLive. 
fantastic. sorry, i cannot remember what option or parameter it was
that made it work. each time i run alsaconf now, with or without
parameters, it shows "rebuilding soundcard database..." and it works.

then i had to unload the OSS kernel modules. it took me some minutes
before i understood which modules were dependent on which so i could
ge the right order of unloading the modules. also i had no clue which
ones were actually for OSS as there is no OSS in any name. i just
plainly unloaded every module that referred to sound.   =)   now my
alsa driver started.

unmuting channels for the SBLIVE with alsamixer gave a problem that i
could not get sound, even with all sliders at 100% and unmuted. the
solution was to use the Gnome OSS mixer (!) and turn up the
appropriate 'wave' or so channel. saving these settings with alsactl
gives me sound after every reboot.

[QUESTION] what is that mixer with tons of sliders for the SBLive
that i heard about??

in the chapter "bring your Hat up" i got an error after doing the
apt-get update; apt-get dist-upgrade;

Fetched 72.4MB in 1m1s (1169kB/s)
Executing RPM (-e)...
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Operation not permitted
error: cannot open /var/lib/rpm/packages.rpm
Executing RPM (-Uvh)...
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Operation not permitted
error: cannot open Packages database in /var/lib/rpm
E: Sub-process /bin/rpm returned an error code (255)
E: Sub-process /bin/rpm returned an error code (1)
[root@localhost root]# 

great. so i quickly found out that var/lib/rpm/ was created and owned
by user rpm and user 'root' was not in group 'rpm'. could this be it?
after adding 'root' to group rpm my pain was over.

ergo conclusio:
after approx 2 hours of installing a fresh RH73 and CCRMA with most
of the time spend waiting for install and/or apt i can say that i'm
very happy with the whole concept. also, the RH installer is not bad.
i like the partitioning tool from Mandrake though. 

for a next time i might make a script with all the commands in
itsince i know now that every step in the documentation was
successful. but, i can also try RH80 with the three apt-RH cdroms and
the one-command install of all sound or video apps. life is sweet...

great work, thanks to Fernando and all who helpt.

Yahoo! Plus
For a better Internet experience