[PlanetCCRMA] Kernel 2.4.20-4.ll.acpi won't boot

Mark Knecht markknecht@attbi.com
Tue Apr 8 21:41:02 2003

On Tue, 2003-04-08 at 16:35, John Wheeler wrote:
> >From: Mark Knecht <markknecht@attbi.com>
> >CC: John Wheeler <jdw27_42@hotmail.com>, PlanetCCRMA 
> ><planetccrma@ccrma.stanford.edu>
> >Subject: Re: [PlanetCCRMA] Kernel 2.4.20-4.ll.acpi won't boot
> >Date: 06 Apr 2003 07:20:45 -0700
> >
> >I saw this on one lab machine of mine at work on a kernel I built. (Not
> >a Planet kernel.) I have 4 Asus A7V133 machines for doing 1394 testing.
> >I eventually determined (in my case) that if I was trying to boot to an
> >ext3 partition AND I had a separate boot partition, my kernel refused to
> >recognize labels for booting. It would however boot fine if I used
> >something like:
> >
> >title Red Hat Linux (2.4.18-14)
> >         root (hd0,4)
> >         kernel /boot/vmlinuz-2.4.18-14 ro root=/dev/hda6
> >         initrd /boot/initrd-2.4.18-14.img
> Hmm, I thought I had done that.  I do have a separate boot partition. (All 
> my linux partitions are ext3.)  I tried making the change again, and while I 
> got the same warning, I was able to successfully boot.  (BTW, first I tried 
> pci=noacpi instead of acpi=off, but that failed miserably.)  I still don't 
> understand why I didn't get the warning message (and root=LABEL=/ worked) 
> with 2.4.18 or 19.
I Asked questions about this for two weeks on the Redhat reflectors.
Others said they had seen it also. They never figured out what really
caused it. Neither did I. Many people didn't see it.

Are your 2.4.18 and 19 kernels RH or from kernel.org?