[PlanetCCRMA] No /etc/asound.state

Dominic Chambers dominic.chambers@bigfoot.com
Mon Dec 23 16:49:01 2002

Hello Fernando,

Thanks for a very speedy response. You were quite right, I completely
screwed up the first installation so I have done the whole thing again
from scratch.

This time everything appeared to go fine (no complaints from alsaconf
and all the other utilities seem happy) but the sound card (Terratec
EWS88MT) does not work at all in alsaplayer, which waits indefinitely
while trying OSS compatability mode. Most other applications fail also,
except MPlayer which works but the volume controls have no effect.

The built in sound card (Cirrus Logic cs46xx) also installs without a
hitch, and this time works fine in OSS mode but not in ALSA. I was
careful to delete the asound.state file before switchng sound cards so
that this was re-generated, but that made no difference either.

I am guessing that the Terratec EWS88MT is not actually supported even
though it says it is at the ALSA web site. The mixer utilities both show
a heap of stuff that the Terratec doesn't even have which makes me
suspect the asound.state file is not quite right.

The comments inline are probably of little interest, and if so only
because they chronicle the misadventures of a Linux idiot (me), and
because they may help others of my ilk in the future.

On Sun, 2002-12-22 at 05:46, Fernando Pablo Lopez-Lezcano wrote: 
> > I am having trouble installing the ALSA drivers, and am informed "No
> > mixer config in /etc/asound.state, you have to unmute your card!" after
> > running alsaconf. I tried creating the modules.conf file manually using
> > the template you provide, and it does the same thing.
> > 
> > It all seemed to boil down to the fact that I do not have an
> > "/etc/asound.state" file on my machine. I had a look on the web for one
> > and couldn't find one, but everyone says to use 'alsaconf store' to
> > create one automatically. Unfortunately this does not work for me.
> > 
> > This is what it looks like from my console:
> > 
> > [root@gateway root]# /etc/rc.d/init.d/alsasound start
> > Starting sound driver snd-ice1712                          [  OK  ]
> > Starting sequencer driver snd-seq-midi                     [  OK  ]
> > No mixer config in /etc/asound.state, you have to unmute your card!
> > [root@gateway root]# alsamixer
> > 
> > alsamixer: function snd_ctl_open failed for default: No such file or
> > directory
> This is wrong, something seems to be missing in your installation. What
> soundcard do you have? (Midiman?). What do you see if you do a "cat
> /proc/asound/cards" and "cat /proc/asound/devices" from a terminal
> window? Do you have a /dev/snd link? (it should have been created when
> you installed the alsa drivers). 

I have a Terratec EWS88MT, and the result of both of the cat commands is
"No such file or directory".

> Just to make sure you have everything installed could you do a:
>   rpm -q -a | grep ^alsa
> and post or email me the results?


> It would seem like you don't have the proper device files. Hmmm, maybe
> you tried to manually install things before? It could be library or
> other files that are lefovers from a previous install. 

Okay, time to come clean:

I first tried to install from the RPMs linked to in the documentation
but this failed because there was a dependency on alsa-sound-modules
which no longer appeared to be available. Then I went the apt route, and
everything went fine. Later I tried to install rosegarden; when I saw
that it was not listed I smelt a rat! I hadn't RTFM, I was using a
vanilla apt install, and it was still pointing to freshrpm.org. Ahh!

Initially this appeared to be fortunate because the alsa-sound-modules
dependency was mirrored in the ccrma apt database. I tried again the
next day and, magically, a new version of the alsa-driver and acpi
kernel had materialized, and I was able to do a complete alsa
installation using the RPMs from your database. Since that didn't work,
I must presume the damage was already done.

This fiasco probably only occurred because I chose the ACPI
installation; my reasoning at the time was that it seemed to have more
'stuff' and a slightly newer kernel version. Having since discovered
that ACPI is a power management system that my computer does not
support, and that the ACPI distribution is still experimental, I feel
that I may have used the wrong criteria for that decision!

Thanks, Dominic.

> -- Fernando


Dominic Chambers <dominic.chambers@bigfoot.com>