[CM] Re: CM 2.6.0 on Tiger, slime support

Rick Taube taube@uiuc.edu
Mon, 16 May 2005 06:20:24 -0500

> Hi Rick,
> on Tiger my CM.app doesn't find Emacs.

I think the Japanese Emacs group has a Tiger build of Emacs :


Ive been using their (Panther) version for several weeks now and like 
it very much. If you want  normal Mac keyboard shortcuts available on 
the Apple key,  turn on their "Mac Key mode" by adding add this to your 
.emacs file:

There is another Emacs called AquaMacs that you could try, I posted a 
message about the new OS X Emacsen last week. I guess I should update 
CM emacs page.

While im on Emacs topics, CVS versions of cm.sh and cm.el are now 
"slime aware", that is, they use Slime as the Lisp connection if your 
initfile loaded slime. cm.el also defines (but does not install) an 
alternate C-x C-e that evals at point, in region and after exprs and 
prints the results in the REPL. If you are on OSX it installs the 
command on APPLE-E. Ive tried out slime for several weeks now but am 
probably going to stop using it -- i spend more time dealing with its 
idosyncracies  than its worth. i still cant fix the readtable problem.  
Last week i spent several hours debugging a weird package error that 
turned out not to be a problem once i ditched slime!


On May 16, 2005, at 5:38 AM, kyburz@uni.de wrote:

> Hi Rick,
> on Tiger my CM.app doesn't find Emacs.
> locations:
> Applications/CM.app
> Applications/Emacs.app
> Applications/Utilities/X11.app
> These paths (with CM 2.4.2 and Emacs 21) work fine on my laptop with 
> OS 10.3..
> I tried two Emacs versions:
> Emacs 21 (30.5.04): dragging the Emacs file from the disk image to the 
> Applications folder
> creates just the Emacs program, which I cannot start.
> Emacs 22 (from http://www.mindlube.com/products/emacs/): Dragging the 
> Emacs file from the
> disk image to the Applications folder creates a folder called 
> DarwinPorts with the Emacs.app
> in it. This is the only Emacs which I am able to start up.
> In either case CM 2.6.0 from Sourceforge doesn't start up because it 
> cannot find Emacs. I
> had downloaded cm_2.6.0-app-osx.dmg.gz from Sourceforge and after 
> expansion I dragged the
> cm.app file to the Applications folder (dragging the diskimage icon to 
> the folder didn't
> work).
> May be also I did something wrong when I installed X11? I tried to 
> download it using the
> link in your readme-or-die: 
> http://www.apple.com/macosx/features/x11/download/, but it
> doesn't work anymore. So I installed it from the Tiger CD XTools. X11 
> is now located in the
> Utilities folder inside Applications.
> I don't like to bother you with these silly installation problems, but 
> I have got stuck with
> it now for three days and so I had to ask you. Sorry.
> Best greetings,
> Hanspeter Kyburz
> -- 
> _______________________________________________
> Get your free email from http://webmail.uni.de
> Powered by Outblaze