[PlanetCCRMA] Problem when grabbing a video from Firewire, probably because of access configuration

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Fri Dec 1 22:51:29 PST 2017

On 12/01/2017 01:06 PM, Yoann LE BARS wrote:
> Hello everybody out there!

Hi Yoann,

> 	I get a strange error when I try to grab video from my recorder
> connected to my desktop computer (which runs Fedora 27 and Planet CCRMA)
> using Firewire:
> $ dvgrab --autosplit --timestamp --format hdv session-
> raw1394 - failed to get handle: No space left on device.

Weird, I have not tried firewire capture in a long long time. Do you see 
any messages in dmesg or /var/log/messages that might be related (and 
give a clue)?.

Another debugging option would be to use strace and see which system 
call is triggering the error (in a terminal do "strace program &> 
trace_log", ctrl-c out of it and then look at what happens towards the 

What about permissions in /dev/raw1394 (and other 1394 device files)?, 
including selinux contexts (might be in a different location?). There is 
also /var/log/audit/audit.log, I think, there could be selinux messages 

Yet another test could be to boot into the Fedora kernel and try again 
(to see if this is somehow related to the RT patches). Or even to try to 
run as root (yuck!) to see if there is something permission related that 
gets fixed that way.

Sorry to not have solutions...
-- Fernando

> 	There is probably no problem with space on disk (nor on the video
> tape), as I have been able to grab the video clip on my laptop computer
> (which runs Debian 9) and then put the video on the hard-drive of my
> desktop computer. As I have more than 70 GiO available on my desktop
> computer, I think we cannot say I am short in space.
> 	I have been looking on the Internet, I did not find anything hat would
> help me to solve this. I have tried to add the following rules:
> $ $ cat /etc/udev/rules.d/95_firewire.rules
> # /etc/udev/rules.d/z95_firewire.rules
> # Set GROUP="video" for some IEEE 1394 device types, driven by the new
> firewire stack.
> # We cannot use the GROUP directive because the significant device type
> attributes
> # live in child devices. So change the group after the fact with chgrp.
> # IIDC devices: industrial cameras and some webcams
> KERNEL=="dv1394*|video1394*|raw1394*|fw[0-9]*",    GROUP="video"
> # libraw1394 older than v2.0.1 and some special-purpose applications
> also need
> # access to the local node(s).  Alas there is no simple way to tell
> local nodes apart
> # from remote ones; here is a simple hack.
> SUBSYSTEM=="firewire", ATTR{vendor_name}=="Linux Firewire", GROUP="video"
> 	And I have added myself to the group “video”:
> $ groups
> yoann wheel video
> 	After reboot, I still have the same problem. As Dvgrab used to be part
> of Planet CCRMA packages, and as Planet CCRMA core is changing rights, I
> wonder if one of you would have any idea on how to solve this – I mean,
> in another way than grab videos on my laptop and then put them on my
> desktop computer.
> 	Regards.

More information about the PlanetCCRMA mailing list