[PlanetCCRMA] JACK 1 vs 2

Don Estabrook don.estabrook at gmail.com
Thu Apr 16 13:16:00 PDT 2015

Hi Fernando and all,

I've been doing some light testing of an Ardour4 rc build in the last day
or so, and I ran into some issues with JACK2 1.9.10 - the current version
for Fedora 21, including:

  - Ardour UI locked up at the end of exporting; had to kill it.
  - After restarting, UI is "awake" but, eg, clicking on buttons doesn't
have the intended effect; Session > Quit also didn't quit Ardour, so
eventually had to kill that one too.
  - The second kill results in a run-away jackd process.

Other issues have been mentioned in Ardour-land as well, including the lack
of an option (-T) that allows for Ardour to stop JACK itself, if it started
JACK when the session was opened.  Apparently that's been added to a newer
version of JACK2, but it doesn't seem to have been published yet -- even in
Git, the latest tag is 1.9.10.

I built JACK1 0.124.1 - itself over a year old - from source, and ran
qjackctl and Ardour with PATH and LD_LIBRARY_PATH augmented to pick up my
JACK1 installation[1], and with that I haven't seen a single issue so far.
As a (minor) bonus, qjackctl and Ardour now show 100% DSP load during
export, whereas JACK2 typically showed 8-10%.  (This has been the case for
some time, even with A3.)

So, just wondering whether others have seen any of these issues.  If so,
might it make sense for CCRMA (or, Fedora?) to switch to JACK1 ?  Or are
there dependencies on JACK2 functionality that would make that problematic?


[1] - Note that this is *not* the recommended installation method.  In fact
the JACK web site clearly states that > 1 JACK installation on a machine is
a recipe for failure.  At the time I was in a hurry to test, and it worked
for what I was doing at least.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ccrma-mail.stanford.edu/pipermail/planetccrma/attachments/20150416/74b33e03/attachment.html 

More information about the PlanetCCRMA mailing list