[PlanetCCRMA] Fedora Installation Help

Donald Steven t6sn7gt at aim.com
Tue Apr 8 09:03:46 PDT 2014


I can't speak to all your problems, but I had many issues with 
Pulseaudio. I've learned to disable it (to just be using ALSA or Jack) 
using the following, much of which I found out there on the web. This 
works for me.


FIRST, clean up all the extra *pulse* PA packages out of your system 
that can be removed:


NEXT, you will likely be left with the packages below: Try to remove 
what you, especially Pulseaudio itself. Be careful though as some may 
not be able to be removed without harm to other components:


NEXT, open gnome-session-properties (Menu -> System -> Preferences -> 
Startup Applications) dialog and scroll to the bottom. There is listed 
an item entitled “PulseAudio Sound System” – go ahead and remove the 
checkmark from that option to disable it and close the dialog, saving 
your options.

LAST STEP, stop the actual /usr/bin/pulseaudio binary from autospawning 
in the background. In your home directory there is a .pulse subdirectory 
(~/.pulse/) that stores per-user config files that are read before the 
system defaults are attempted to be used (if per-user are missing). 
Create a new file called client.conf in this directory:

$ nano ~/.pulse/client.conf

…and place these two lines in that file and save it:

autospawn = no
daemon-binary = /bin/true

These options should be a little self explanitory, we’re telling the 
system to not autospawn the binary but just in case it does we’re also 
telling it to run /bin/true instead of the real PA application.

Log out, log in (perhaps reboot) and – no more Pulseaudio

NOTE: Sometimes, an update to something or other will pull in Pulseaudio 
related stuff and your sound will disappear. Check again 'from the top' 
and all should be well.


On 04/08/2014 10:37 AM, Brian wrote:
> Hi y'all,
> Can anyone recommend a responsive and responsible forum for 
> installation help?
> I've been flailing with the Planet CCRMA since about Fedora 6, 
> modprobing madly to get my
> Audigy recognized and trying (mostly in vain) to mediate between 
> PulseAudio and Alsa.
> In my early days on a screaming 600 MHz machine I'd fire up Ardour and 
> 45 minutes later
> it would still be trying to draw the first screen. Mostly I just use 
> Audacity, Hydrogen, and
> Zynaddsubfx in Windows--because they work. Recently I actually briefly 
> got Jack to work
> In Fedora 19 with Hydrogen and Zynaddsubfx--a major breakthrough for 
> me which was soon
> wiped out when I played a Youtube and I guess the flashplayer reset 
> the audio to some
> configuration foreign to Jack.
> So I rashly decided to upgrade to Fedora 20 and see if they've fixed 
> some of this. The Live
> DVD just put multicolored snow on the screen. So I tried a Yum update 
> and it neglected to
> bring in the keys. And then though I'd get the Fedora ice cream cone 
> I'd get no login screen
> and no terminal. After I learned to append a "3" to the vmlinuz line 
> in the grub script I got
> my terminal and yum seemed to be chugging along but after I tried to 
> update grub I only get
> grub rescue. Using that I identified the location of the carcasses of 
> my long-defunct Fedora
> 10 and Fedora 11 installations and found my Fedora 19 and 20 
> installations, but at this point
> I need some hand-holding because I am very near but still so far away.
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

More information about the PlanetCCRMA mailing list