[PlanetCCRMA] Can't install fedora 17 on dual-boot UEFI system

Michael J. Wilson mwilson at alumni.caltech.edu
Tue Aug 7 22:20:14 PDT 2012


It may be that you need a separate /boot partition:


"If your 64-bit x86 system uses UEFI instead of BIOS, you will need to 
manually create a /boot partition. This partition must have an ext3 file 
system. If you choose to partition automatically, your system will not 

If you have already tried this could you please list your current and 
desired partition layouts?  Also perhaps your machine type?  I have been 
successfully dual-booting Windows 7 and F16 64-bit on a UEFI system so 
it can be done!  Also, I have been able to use ext4 on my boot 
partitions but I'm not sure if this is not recommended.

-Michael J. Wilson

On 08/07/2012 01:01 PM, Stephan Neuhaus wrote:
> Dear list,
> after countless attempts of installing PlanetCCRMA on a new Intel x86_64 system, I'm ready to give up, since I can't even seem to get past the first step, which is installing Fedora!
> My system has Windows 7 already installed, and it's booting in (U)EFI mode.  I boot into the FC17 x86_64 DVD (which loads "Linux_EFI" or some such) and get to the disk partitioning stage. Since I have Win7 already installed, I choose "custom partitioning" (or whatever it's called) and reduce the size of the Win7 partition, making way for a new ext4 root partition.  I also have another disk installed, and have partitioned that also. The situation is thus:
> * The old NTFS root partition is about to be reduced in size
> * The resulting free space is about to be made into an etx4 partition
> * There already exists an EFI System Partition, that is, however, not earmarked for formatting
> * Another disk is partitioned into various ext4 partitions
> When I then click "Next", the installer tells me that I haven't created a suitable "stage1 boot device". Googling this, I am told that I have to create a "1 MB BIOS boot partition", which is nonsense, since I'm booting in EFI mode (I tried anyway, and it didn't work). Other ideas, such as using a USB stick, have also failed, following the Fedora website recipes. All these attempts resulted in a "File not found" error, and yes, I know about "/syslinux" vs. "/isolinux"
> Can anyone please help me here? Since PlanetCCRMA is the only reason for me to use Linux at all, I am this -><- close to abandoning it altogether.
> Best,
> Stephan
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

More information about the PlanetCCRMA mailing list