[PlanetCCRMA] F15 + CCRMA = no X on start, no network, long boot time and instability

Geoff King gsking1 at gmail.com
Sat Jul 2 08:00:37 PDT 2011

Hi Dale, A few things that might help (note I'm still on FC14, but probably
not significantly different in commands):

1) Holding down Shift while booting should bring up boot menu.
2) Once you are sure a kernel setting works you can edit /boot/grub/menu.lst
but be careful
3) Install yumex and try to manage rpm packages with that. I find it easier
to use most of the time. You shouldn't need to reinstall Fedora in your
example, just remove the offending packages.
4) FWIW - the rt kernel doesn't work well on my current desktop machine
either (quad core i5). It boots, but eventually locks up after a few
minutes.  For the last few months I've been using a low latency kernel based
on the FC14 generic that I build myself and works for my use.  However, the
rt kernel worked great on a prior machine of mine in the past.
5) Assuming you are on wireless,  I'm not suprised that you are having some
network issues.  Wireless can sometimes be problematic with linux especially
if changing around kernels and such.  Maybe someone will have some advice? I
use ethernet cable and never have any problems.  What is your network device
6) I doubt you will have any dual boot problems, but haven't done that for a
several  years.  I found I don't like to switch OS back and forth decided to
stick with linux.  Maybe others have an opinion?
7) Not getting X?  What is your video card make and model?  What are your
system specs, type model, 32bit or 64bit?  I probably won't know how to
help, but this is some basic info you should provide when asking for help.
If you have nvidia card, search the mailing list and web, there is tons of
advice on the net about how to get those working using akmod or kmod.
8) Ask yourself if you really need a full rt kernel or does a more stock
system like FC15 or latest ubuntu work well enough for your purposes?  There
are compromises that sometimes have to be made.   What do you hope to gain
from going full rt vs. standard setup?

Hope this helps.


On Sat, Jul 2, 2011 at 6:18 AM, Dale Powell <dj_kaza at hotmail.com> wrote:

>  Just installed Fedora15 on a new hard drive in my laptop. As the first
> distribution I have tried that will loose wireless connection and reconnect
> without me having to restart the laptop to get the network working again I
> really do want to go for F15 over F14 even though CCRMA/RT-Kernel hasn't
> quite caught up with it yet.******
>  ****
> Ran the installation.****
> Ran Yum Update****
> Added RPMFusion Free and NonFree, plus CCRMA depositories****
> Removed Parole****
> Installed XMMS plus Gstreamer plugs Bad, Ugly and FFMPEG****
> (Very basics and at this point would boot up very quickly, didn't time it
> but would say 20-30sec.)****
>  ****
> Slightly worried at this point that I did not have a GRUB Boot menu at
> loading. Especially as I do plan to have a Windows partition on there as
> well. Previously have always had Windows installed first... But at that
> point I didn't know if there was maybe no kernel update thus no need to
> select which you use at startup.****
>  ****
> installonly_limit=3 which I didn't change to 0 for unlimited but still I
> thought should of given me the option between kernels at boot but didn't
> seem to, automatically loading into most recent. How do I change this and is
> installing Windows (most likely XP, maybe Win7 if I ge around to upgrading)
> later going to cause any problems?****
>  ****
>  ****
> Anyway thought I'd try the planetccrma-core as should have the choice so
> ran 'yum install planetccrma-core' then tried restarting.****
>  ****
> Laptop took ages to boot up, a couple of minutes, at least 3-4 times as
> long if not longer than before. I tried restarting a couple of times to make
> sure wasn't only due to running the first time after changes.****
> Not only that but it only booted into command line, with me having to log
> in the run 'startx' to get the graphical environment (but at least it
> worked.)****
> Once there I found my Network widget had disappeared so I had no access to
> the internet. Trying to find the Network Manager and the system completely
> froze on me, requiring a hard reset.****
> At this point I decided to just reinstall F15 vanilla and not use the CCRMA
> Core for the moment!****
>  ****
>  ****
> As you can tell I'm fairly new to Linux, some Ubuntu use and a little with
> F14 previously. Comments on the above appreciated. Hints and tips on what I
> did wrong (if anything) or any more information you would like to have from
> me regarding it appreciated.****
> ** **
> ** **
> Many thanks, Dale.
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ccrma-mail.stanford.edu/pipermail/planetccrma/attachments/20110702/270428b0/attachment.html 

More information about the PlanetCCRMA mailing list