[PlanetCCRMA] [SOLVED] firewire on CCRMA-Fedora-12

linux media 4 linuxmedia4 at netscape.net
Tue Sep 21 20:49:56 PDT 2010

>> Hi,
>> This week I installed CCRMA-Fedora-13 but had to abandon it because I
>> couldn't get the firewire driver working with my Focusright Saffire Pro
>> 10 (the jack ports had long numerical names and wouldn't let certain
>> ports connect with other ports). I googled around for quite a while, but
>> found no solution.
>> So I installed CCRMA-Fedora-12. At first it was saying that it couldn't
>> find jack_firewire.so, but I found a post that mentioned that you have
>> to install libffado-devel (along with libffado of course). But now jackd
>> fails with the message:
>> bash>   /usr/bin/jackd -dfirewire -r96000 -p1024 -n3
>> [CUT]
>> JACK server starting in realtime mode with priority 60
>> 01345759929:  (ffado.cpp)[  92] ffado_streaming_init: libffado 2.999.0-
>> built Jul 18 2010 21:25:26
>> firewire ERR: FFADO: Error creating virtual device
>> Cannot attach audio driver
>> JackServer::Open() failed with -1
>> no message buffer overruns
>> Failed to start server
>> I did a bit of googling around tonight but ran out of time. Does anyone
>> know how to get this working?
>> Here are the details...
>> bash>   uname -r
>> bash>   yum list jack-audio-connection-kit
>> Installed Packages
>> jack-audio-connection-kit.i686  1.9.4-1.fc12.ccrma  @planetccrma
>> bash>   yum list ffado
>> Installed Packages
>> ffado.i686  2.0.1-3.20100706.svn1864.fc12  @updates
>> bash>   yum list libraw1394
>> Installed Packages  libraw1394.i686 2.0.5-2.fc12 @updates
>> Any ideas of how to get firewire working would be appreciated. I would
>> prefer to work with CCRMA-Fedora-12 because it's already up and running,
>> and besides, I couldn't get my wireless connection working with
>> CCRMA-Fedora-13.
>> Thanks,
>> Rocco

> Following a hint while googling, I temporarily changed the permissions
> on /dev/raw1394 to make myself the owner. It worked. So that tells me
> the base of the problem.
> As you can see...
> bash>  ls -la /dev/raw1394
> crw-rw---- 1 root root 171, 0 2010-09-20 21:54 /dev/raw1394
> ... raw1394 is in the group "root".
> I seldom ask anyone to hold my hand, but all the googling isn't telling
> me how to properly set up firewire to allow "normal users" to use it,
> and I don't want to experiment with things that can cause problems on my
> system. There seems to be a lot of layers to setting up permissions and
> I'm not understanding. What is the proper way of setting things up to
> allow normal users to access firewire?
> Thank you,
> Rocco

I want to include what I did to allow a normal user to have access to 
firewire, in case anyone else runs into this situation...

Create the file:

Copy this into the file:
KERNEL=="raw1394", NAME="raw1394", GROUP="audio"

Use an application to make a user part of the group "audio"
In KDE I went to:
-> Administration
-> Users and Groups
-> Click "Users" Tab
-> highlight user you want to add to the audio group
-> Click "Properties"
-> Choose "Groups" Tab
-> Check the "audio" group

If no application exists, then, in the file "/etc/group" add the user's 
name at the end of "audio". For instance, mine looks like this...



More information about the PlanetCCRMA mailing list