[PlanetCCRMA] Basic Newbie stuff

Geoff King gsking1 at gmail.com
Sun Sep 5 19:04:20 PDT 2010

Hi Lloyd, 

First triple check all cables and connections, there are alot going into
and out of this card. 

Second, it could be this bug is affecting you as I presume you have
pulseaudio installed.

Particularly see posts #52/53 for a workaround. Although this is for
Ubuntu I think it also affects fedora, but am not certain anymore since
I removed pulseaudio several months ago.  Since I normally just use pro
audio programs with qjackctl/jackd, i don't need pulseaudio.    

Removing pulseaudio fixes the "bug", but takes away some functionality
(mixing of multiple audio streams from desktop applications).  For
example, you want pulse if you are surfing youtube and listening to
music at the same time, otherwise one will get blocked.

Beyond that I have done quite a bit of customization which I think has
helped the performance and latency a little. Sorry no good links to
anything comprehensive.  It took me a fair amount of tweaking, but I'm
very happy at this time.  

removed abrt.. (don't need it and gave warrnings in dmesg)

removed pulseaudio. (don't need it, just using ALSA directly)

removed NetworkManager for performance gains [but get ifup working
first](start network with "ifup eth0" , need to work on file ifcfg-eth0)
can also stop service

disabled SElinux using policycoreutils-gui and menus
added me to audio and disk groups using GUI in System -> Admin

Disabled or stopped other services that I don't use such as: nfs,
nfslock, rpcbind, rpcgssd, rpcgssd, rpcidmapd, rpcsvcgssd, wine, auditd,
cups, openvpn  [not sure this list is correct, be careful]

after startup login as su/root from a terminal and use this to enable
the rtc and snd_hrtimer for better timing:
chmod 666 /dev/rtc0 && echo 2048 >/sys/class/rtc/rtc0/max_user_freq &&
cat /sys/class/rtc/rtc0/max_user_freq && modprobe snd_hrtimer

boot with acpi=off   [I need it when using rtc or snd_hrtimer, could
just be my weird bios though]

Hope this helps you along your journey. 


On Sun, 2010-09-05 at 21:24 -0400, Lloyd Hanson wrote:
> I've been following the list for years with a different email, but have 
> never gotten serious about setting up a system.  Now I'm trying and 
> failing miserably.
> Can anyone point me to a tutorial to get a Delta1010LT up and running?
> I started with a new machine consisting of:
> Asus M4N75TD mobo with Athlon II X4 635 CPU, 8 gigs of memory, ATI 
> video, and a brand new Delta1010LT.
> Turned off the onboard sound chip in BIOS.  Blacklisted the Intel HDA 
> HDMI chip in /etc/modprobe.d/blacklist.conf
> I can get no audio from the system.
> I initially tried with FC13-64bit.  unsuccessful with that, so I wiped 
> the drive and started over with FC12-64 bit.  Still no joy.
> Since then, I have moved the card to an existing WinXP machine and once 
> the win drivers are installed it comes right up with audio out on line 
> out 1 and 2.
> Also, installed another HD to the new box and installed Vista-64bit .  
> Only thing I had to do there was change the default output from the 
> SPDIF out to line out 1 and 2.
> cat /proc/asound/cards returns:
> $ cat /proc/asound/cards
>   0 [M1010LT        ]: ICE1712 - M Audio Delta 1010LT
>                        M Audio Delta 1010LT at 0xdc00, irq 19
> Any PlanetCCRMA for newbies pointers is greatly appreciated.
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

More information about the PlanetCCRMA mailing list