[PlanetCCRMA] supercollider libscsynth.so (Fernando Lopez-Lezcano)

Joshua Parmenter joshp at u.washington.edu
Fri Jan 22 11:05:01 PST 2010

Hi Fernando (all)...

I don't have a way at the moment to test this, but in the past few weeks a number of changes were made to get a 64-bit sclang working, mostly due to the hard work of Tim Blechman. It would be worth asking about this on the SuperCollider users or dev list, as I believe a number of people (or at least Tim) has sclang running in 64-bit.

Sorry I can't be of more help at the moment.



On Jan 22, 2010, at 10:58 AM, planetccrma-request at ccrma.Stanford.EDU wrote:

> Message: 9
> Date: Fri, 22 Jan 2010 18:48:51 +0000
> From: Fernando Lopez-Lezcano <nando at ccrma.Stanford.EDU>
> Subject: Re: [PlanetCCRMA] supercollider libscsynth.so
> To: Tracey Hytry <shakti at bayarea.net>
> Cc: planetccrma at ccrma.Stanford.EDU
> Message-ID: <1264186131.14437.39.camel at localhost.localdomain>
> Content-Type: text/plain
> On Fri, 2010-01-22 at 10:00 -0800, Fernando Lopez-Lezcano wrote:
>> On Thu, 2010-01-21 at 16:18 -0800, Tracey Hytry wrote:
>>> I should have said something about this a long time ago.
>>> I haven't been able to run supercollider in 64 bit forever and gave up trying.
>>> Now that SC mentioned it, I tried yum install supercollider on my fedora 11 x86_64 here
>>> and I got exactly the same message as SC (it wanted the i586 versions instead of i686).
>>> It would be nice if it worked on 64 bit.  After a while I just started to assume it didn't.
>> SC is problematic. The language itself (sclang) works only on 32 bit
>> linux, not 64 bit. The synthesis engine (scsynth) works on both 32 and
>> 64 bit linux. I had never tried to make that work, I think it does in
>> Ubuntu. The idea would be to run the language 32 bit and the rest on 64
>> using mixed libraries. It does not appear to work. 
>> The problem you are all seeing is a result of a packaging mistake (wrong
>> mixed 32/64 bit provides). I just did a rebuild to fix that manually but
>> I can't make things work either - it installs now but does not run. 
>> When trying to start sclang (which is the same package as the 32 bit
>> version) it complains about not findinf libscsynth.so. Reasonable as
>> that is now in /usr/lib64 and not /usr/lib. Adding a
>> LD_LIBRARY_PATH=/usr/lib64 to the startup line brings up a "wrong ELF
>> class: ELFCLASS64" error message. So it would seem it does need a 32 bit
>> scsynth as well...
> I have released another iteration of the package that splits libscsynth
> into a separate package. That allows the install to proceed and sclang
> starts in a fc12 chroot - that's my only test so far. 
> Let me know if it actually works (I don't currently have a real 64 bit
> install to test). 
> -- Fernando

Joshua Parmenter
University of Washington
Center for Digital Arts and Experimental Media
Seattle, Washington 98195


More information about the PlanetCCRMA mailing list