[PlanetCCRMA] help w/ qjackctl locks-up X/GUI (perhaps caused by dbus or kernel

Niels Mayer nielsmayer at gmail.com
Mon Apr 12 11:00:54 PDT 2010

qjackctl-0.3.6-1.fc12.x86_64, when run out of my son's account on his
computer causes the entire X/Gnome GUI to "hang" until qjackctl is killed
Using the same account, running qjackctl w/ remote X display set to my
computer causes my X/Gnome GUI to "hang" until qjackctl is killed.

qjackctl runs fine on my computer and also runs fine from my account on my
son's computer.

Although the hardware on the computers is different (Opteron 1220 vs
PhenomII 965, difft mobos) the "music" hardware controlled by jack is the
same -- M-audio delta-66 and an Emagic MT4 USB midi box.

The debugging I've done so far indicates the lockup is caused by dbus. The
problem is, I can't even change parameters in qjackctl on my son's account,
because bringing up qjackctl locks up the computer. Are there any other
files I should consider resetting -- given that, for the same computer, my
config files "work" whereas his account results in a instant lockup on use
of qjackctl.

Where does qjackctl store it's setup? Any suggestions on what config-files I
can hand-edit to get things working again for his music-making? I'm
considering reverting to the previous kernel to see if that's what caused
the breakage. This worked fine prior to updates done recently, including a
new kernel update.


PS: I did notice some oddities with this new kernel. For example, one time
on my box, my Emagic MT4 usb midi started up with a different set of lights
on than usual, and never actually went into "USB" mode. Unplugging and
replugging got it recognized, and likewise rebooting again -- worked fine.
This has not happened prior to update to one of these kernels:


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ccrma-mail.stanford.edu/pipermail/planetccrma/attachments/20100412/85a28361/attachment.html 

More information about the PlanetCCRMA mailing list