[PlanetCCRMA] setting up new system with Delta 1010LT + Intel HDA

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Sat Nov 28 10:51:41 PST 2009

On Sat, 2009-11-28 at 06:34 -0800, Bruce Elliott wrote:
> This was actually my first attempt at performing an upgrade; the few
> installations I've ever completed were always on new drives.  I was
> hoping that by doing an upgrade instead, my home directory and
> configuration would be retained, including things like installed
> Firefox plugins and so forth, which I have always had to re-install in
> the past. 

yes, that should be the case. 

> I was pleased to see that this upgrade preserved not only much of the
> set-up work I had done, but also the selection of applications that I
> had added, e.g. from CCRMA. Since I have not been able to add the
> Planet CCRMA repositories, I assume these are still the F11 packages,
> if they are truly there at all, but I have not tried running them
> since I don't have the RT kernel. 
> It would be great if an upgrade could be transparent, as far as
> personal settings and configuration go (that's why I run Linux, after
> all), and the only changes were the parts that were truly upgraded.
>  Maybe that's too much to hope for.

I don't know why it could have failed, but it did. Too late now to try
to debug what happened. 

Let's see what's wrong in your current mix of packages. At least you can
boot and login, right?

Open up a terminal, su root (type "su" and then your root password when
prompted) and do a few checks:

(hmmm, you might now have the yum-utils package... if yum is not working
then you might have hit a catch22 - you could download yum-utils from
here[*] and install it with rpm)

  package-cleanup --problems

that will tell you if it works if you currently have unmet dependencies
in your install. 

  package-cleanup --dupes

that will tell you if you have duplicated packages. If your install was
interrupted in the middle you may have _lots_ of these. You can use the
same program with --cleandupes to remove the older duplicated packages. 

  package-cleanup --orphans

will show you packages you have installed that are not in any current
repository (usually leftover packages from previous versions). If you
have a lot of duplicated packages then they will show up here as well. 

You could also boot from the Fedora 11 install media into rescue mode,
chroot into the mounted root and try to fix things from there. 

Let us know how it goes...
-- Fernando

[*] http://koji.fedoraproject.org/koji/buildinfo?buildID=130258

> ______________________________________________________________________
> From: Nicholas Manojlovic <nicholasmanojlovic at gmail.com>
> To: Bruce Elliott <belliott4488 at verizon.net>
> Cc: PlanetCCRMA List <planetccrma at ccrma.stanford.edu>
> Sent: Sat, November 28, 2009 2:37:40 AM
> Subject: Re: [PlanetCCRMA] setting up new system with Delta 1010LT +
> Intel HDA
> It's probably a silly big that is causing the media check to fail. 
> The 'upgrade' method of installing is unreliable, IMO. Its best to
> start from a cleanly formatted drive. I can't work out if this is what
> you did or not. 
> Remember that KDE is not installed unless you select that as an
> option. 
> I never particularly liked Fedora 11 anyway on my hardware - I haven't
> yet given F12 a go. 
> It might be worth having another go at installing again from scratch
> Cheers
> On Sat, Nov 28, 2009 at 4:00 PM, Bruce Elliott
> <belliott4488 at verizon.net> wrote:
>         Stephen,
>         This sounded like a great idea, so I went ahead with full
>         confidence and enthusiasm.  Unfortunately, it hasn't worked
>         out so well.  I downloaded the .iso DVD image (several times
>         before I was done) and attempted the upgrade, but the discs
>         all keep failing the media check at the start.  I've repeated
>         this several times, downloading by torrent, from a mirror,
>         etc., and the sha256 hashes all look good for the .iso files -
>         actually the same file over and over - but they all fail the
>         media check in the same way.  I also created one of the discs
>         on a Windows laptop, in case it was a problem with my DVD
>         drive - same result.
>         On one of my first attempts I tried to see if I could exit the
>         installer gracefully rather than just by doing a hard reset.
>         I had hoped that I would have an option to abandon the
>         installation at some point, but I never did, and the
>         installation just carried along until it finished (with no
>         obvious errors).
>         So now I have Fedora 11, or at least parts of it.  I can't
>         start KDE and if I try to update any software, yum fails.
>         When I go to the graphical interface to add/remove software,
>         all the packages say "no results found". Running yum from the
>         command lines fails with a message about there being no yum
>         python module or something.
>         The good news is that I have sound from Firefox.  The bad news
>         is that I can't do much of anything else.
>         I don't know what the problem is with the (multiple) F11
>         installation disc(s) I created, but now it seems like I'm
>         stuck with this crippled installation until I'm ready to
>         upgrade to F12.
>         What do you suggest?  Are the x86_64 CCRMA packages for F12
>         stable enough for a novice to be able to find his way around?
>         Since it looks like figuring out how to add the CCRMA packages
>         to this broken F11 installation might take some time, I'm
>         tempted just to go ahead and install F12 and wait until the
>         64-bit CCRMA packages are ready, if they're not yet.  Either
>         way, I'm off the planet until then, so I might as well get a
>         healthy Fedora installation while I'm waiting ...
>         - Bruce
>         ______________________________________________________________
>         From: Stephen Stubbs <theother1510 at sbcglobal.net>
>         To: Bruce Elliott <belliott4488 at verizon.net>
>         Cc: PlanetCCRMA List <planetccrma at ccrma.Stanford.EDU>
>         Sent: Tue, November 24, 2009 10:52:15 PM
>         Subject: Re: [PlanetCCRMA] setting up new system with Delta
>         1010LT + Intel HDA
>         Hello Bruce,
>         May I suggest that you install Fedora 11.  Then go to the
>         Fedora home page and join the forum.  A lot of installation
>         problems are handled there.  I'm on the Windows laptop now and
>         can't confirm the exact places, but look for the HowTo from
>         Danger Mouse.  He has a site where you can add all sorts of
>         non-free applications (like a complete MPlayer setup, Flash
>         Player for Firefox, etc.).  Danger Mouse has worked out all
>         the issues.  You simply select what you want from his list and
>         then his script pulls everything in (including any needed
>         repositories) and installs it.  You may have to reboot.  Then
>         the function/program  is good to go.
>         Then check the archives of this list to see exactly what you
>         need to do to add the PlanetCCRMA Fedora 11 repository.
>         Fernando told me how to do it a few months ago.  I think I may
>         have just used the Fedora 10 file path, changed all references
>         to Fedora 11, and got into the repository.
>         Sorry I can't be more specific, but that should give you some
>         pointers.  For myself on Fedora 10, I loaded up everything
>         ALSA with that one exception of Do Not load the ALSA-Pulse
>         connection package, then removed everything that was
>         PulseAudio that I could.  But as I said in the prior post,
>         Fedora 11, ALSA, and PulseAudio seem to playing nice with each
>         other.  So start working with Fedora 11 since it won't be that
>         much longer before Fedora 10 is no longer actively supported.
>         (Fedora only actively supports the most recent 3 versions.)
>         Good Luck,
>         Stephen.
>         _______________________________________________
>         PlanetCCRMA mailing list
>         PlanetCCRMA at ccrma.stanford.edu
>         http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA at ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

More information about the PlanetCCRMA mailing list