[PlanetCCRMA] settings for Pure Data broken?

Kaj Ailomaa ailomaa at msn.com
Thu Jul 16 11:26:51 PDT 2009

I've been using Pure Data with planetccrma for a little while now, and

I've tried out fc9, fc10 and Centos 5.3 as platforms. I have had some

similar problems on all of them, except I got PD working completely

without DIO-errors only on Centos. 

At first this led me to believe it had something to do with Pulseaudio,

since Centos comes without it. Now, after experimenting more with the

settings for PD I am more inclined to believe it is a problem with PD.

These are the problems I've had:

1. Connections to jack does not start automaticly. (solved)

First I used different combinations of these flags while launching the

program: -jack -channels 8 -r 48000 -blocksize 256. 

(I am not sure if any of them really do anything for the audio

connection, except -jack, since the specific audio settings are done in

Jack internally. I have noticed that the latency for midi will only sync

with the latency for audio if I use the flag for -blocksize with a

matching value to that used in Jack settings, in my case 256.)


The flags did not work well, or at all. On Fedora, my system would

sometimes become almost completely frozen if the auto-connection worked.

Massive DIO-errors. On Centos, PD would simply not connect. I had to do

it manually in the menu each time.

Then I started messing with .pdsettings, found in the users home

directory. I got PD to autoconnect to jack, without any flags. These

were the settings I had to add/change:

audioapi: 5 (unchanged)

noaudioin: False (this was set to TRUE) 

audioindev1: 2 (added this line)

noaudioout: False (this was set to TRUE)

audiooutdev: 2 (added this line)

audiobuf: 10 (changed it to 10, originally 50)

rate: 48000 (and this was 44100)


flags : (made sure to leave this blank since the flags seemed not to

work from here. Not even the -rt flag.)

So by including this in the .pdsettings file,

and adding these flags to the launcher command path: -rt -alsamidi

I now have a functional Pure Data on my CentOS.

(remains to be seen it the same goes for Fedora).

2. Loading extra library is tricky

Lately I have needed to use only one external library, namely ext13. So,

I have only installed PD (0.39-3extended-rc5) + this library.

It loads fine, but I am initially unable to use 'r13' (alias


The way I go about it is I make another object called 'send13' (included

in the same library), which works fine. 

Then I retry making one named 'r13' or 'receive13'. 

Sometimes I have to repeat this order of execution until I get 'r13' to

initialize properly, after which it seems to work for the rest of the


This is a little annoying, of course. 

Anyone know what this is about?

And if anyone has any insight to the problems with .pdsettings, please


More than messages–check out the rest of the Windows Live™.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ccrma-mail.stanford.edu/pipermail/planetccrma/attachments/20090716/8b4a313d/attachment.html 

More information about the PlanetCCRMA mailing list