[PlanetCCRMA] updates: new kernel for fc9/10

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Sat Jan 10 19:49:06 PST 2009

On Sat, 2009-01-10 at 19:14 -0800, Tracey Hytry wrote:
> I forgot to add in the last post:
> I got the same errors on fedora9 as Hector was getting on 
> fedora10 with the newest rt-kernels.
> Also, as noted on the dmesg dump that I posted,  I made sure 
> that I used a non-tainted kernel.  The same error also shows 
> up with the rpm-fussion nvidia drivers loaded though.
> If what I suspect about the old ata driver is correct;  

Unless there was a regression somehow in the configuration files I'm
using the old drivers are only used for fc < 7, versions higher than
that use the newer versions (or rather, should - depending on the
version I merge or not the old driver configuration options). 

> it just may be a situation where the rt-patch did not 
> convert the old disk interrupt to the proper futex?  
> But then, I'm a bit(maybe a few bytes) in over my head 
> on this one???

Re: BUGs
This one:

BUG: sleeping function called from invalid context IRQ-14(988) at
in_atomic():0 [00000000], irqs_disabled():1
Pid: 988, comm: IRQ-14 Not tainted
 [<c041ff88>] __might_sleep+0xe8/0xed
 [<c041cd55>] kmap+0x42/0x55
 [<f88d3e1d>] ata_sff_hsm_move+0x3d3/0x66b [libata]
 [<f88d4314>] ata_sff_interrupt+0x153/0x1eb [libata]
 [<c04610a4>] handle_IRQ_event+0x49/0xcd
 [<c04614eb>] do_irqd+0x12b/0x229
 [<c04613c0>] ? do_irqd+0x0/0x229
 [<c043b15b>] kthread+0x3b/0x61
 [<c043b120>] ? kthread+0x0/0x61
 [<c040581f>] kernel_thread_helper+0x7/0x10

I reported to lkml, see the thread here:


A first response by Steve Rostedt leads to Peter and he suggests a patch
he is working on which I tried and led to many errors and a non-booting
machine. No further solutions were offered. 

As usual, thanks for the feedback!
-- Fernando

More information about the PlanetCCRMA mailing list