[PlanetCCRMA] Saffire Pro 10 not working on CCRMA/F10

linux media 4 linuxmedia4 at netscape.net
Fri Feb 27 16:53:18 PST 2009

> On Fri, Feb 27, 2009 at 07:56:35AM -0700, linux media 4 wrote:
>> Everything seems to be running correctly, but I'm not getting sound 
>> (even when
>> I run ffado-mixer). I have googled for days and can't figure how to get 
>> sound on the Saffire Pro 10.
>> I turn on the Saffire Pro 10.
>> I start jack with:
>> jackd -R -dfirewire -r48000 -p256 -n4
>> The Saffire Pro 10 Power light flashes quickly to indicate it is active.
>> I run ecasound:
>> ecasound -r -b:256 -c -f:24,2,48000 -a:monitor -i:jack,system -a:monitor 
>> -o:jack,system
>> (run realtime, buffer:256, interactive mode, 
>> 24bit,2Channel,SampRate48000, In from Jack and back out to Jack)
>> I start QJackCtl and press "Start" and it says "Active" (showing it's 
>> monitoring the already run jackd session)
>> I start ecasound and can see that jack transport is running and checked 
>> and can see that ecasound is running.
>> I run ffado-mixer. The channels are all up, but no sound.
>> On past tests of recording an audio file with ecasound, there was no 
>> sound being monitored and the audio file has *very* faint sound recorded.
>> Anyone know the magic to getting sound to work on this?

David Cornette wrote:
> I don't know enough about the ecasound command line options to be sure it isn't doing this by itself automatically, but are you sure you have connected ecasound's outputs to your audio device's main out?

In QJackCtl "Connections" window, I see:

ecasound out_1 (connected to) system AP0_dev0_Lin1/2 L
ecasound out_2 (connected to) system AP1_dev0_Lin1/2 R
system AC0_dev0_Line1/2 L (connected to) ecasound in_1
system AC1_dev0_Line1/2 R (connected to) ecasound in_2

I am so new to ffado and firewire. Does this look right to you?


More information about the PlanetCCRMA mailing list