[PlanetCCRMA] Saffire Pro 10 not working on CCRMA/F10

linux media 4 linuxmedia4 at netscape.net
Wed Feb 25 12:28:50 PST 2009

David Nielson wrote:
 > Check to make sure you have the raw1394 driver loaded using lsmod and
 > modprobe.

Once I'm booted up I do:
lsmod | grep raw1394
It shows nothing has been loaded.

I turn on the interface, then plug into firewire and do:
lsmod | grep raw1394
It shows nothing has been loaded

I 'su root' and do:
modprobe raw1394
'lsmod | grep raw1394' reveals:
raw1394  24008  0

I turn on the interface and 'cat /proc/asound/cards' doesn't reveal any 
mention of this interface.

Is the interface supposed to show up in the 'cat /proc/asound/cards' output?

 > You might need to download the latest version of libraw1394;
 > 2.0.0 has been out for a while, but most distributions still ship
 > 1.3.something IIRC. I haven't used F10 yet so I can't speak to that.

'yum info libraw1394' reveals:
Name       : libraw1394
Arch       : i386
Version    : 2.0.1
Release    : 1.fc10
Repo       : installed

 > You should probably plug in and turn on the Saffire before booting the
 > computer. Understand that ALSA will have **nothing** to do with the
 > operation of this interface; ffado and ALSA operate independently of
 > each other.

Yeah, tried this several times and will keep trying again.

 > When you start jackd, you must start it with the "firewire" driver
 > instead of the "alsa" driver. This is selected by a drop-down menu in
 > the qjackctl setup window,

Yeah, I do that. In QJackCtl's (Interface) dropdown I see different 
listings. What should I be seeing if this interface was actually reconized?

 > or if you start jack from the command line,
 > by adding "-d firewire" to the command.

Just to keep things simple, I did:
jackd -d firewire
It did start up and the interface suddenly responded with the "quick 
flashing" power light, so something happened. The interface "acts" like 
it's been reconized, but 'cat /proc/asound/cards' doesn't show anything 
relating to this interface.

Don't know if this is important, but jackd outputs the continous message:
JackAudioDriver::ProcessAsync: read error, skip cycle

I tried to record something with ecasound, but 
*_I_have_to_go_to_an_important_meeting_* (darn!!!, just as something was 

I will resume were I was when I get back from my meeting. Meanwhile, 
should I be seeing the interface in 'cat /proc/asound/cards' output?


More information about the PlanetCCRMA mailing list