[PlanetCCRMA] jack and a soundcard

sevol sevols.ear at gmail.com
Tue Aug 11 23:42:48 PDT 2009

On 8/11/09, Bozelos Dimitris <dbozelos at yahoo.gr> wrote:
> hello everyone,
> I run jack in a terminal using the command
> jackd -R -d alsa -r 48000
> when using the internal soundcard of my laptop it works fine but when I use
> an external soundcard (Edirol UA-25) although it runs without displaying an
> error the actual sample rate is 44100. I say so because when I try to run
> ChucK with 48000kHz I get a message that it can't run because jack is 44100
> and also if I run qjackctl it displays jack as running with 44100. Any ideas
> what the problem might be?
> Cheers,
> Dimitris
To start, I don't have an Edirol UA-25 (or any usb audio interface),
so I'm only guessing. Did you see the guide? - here:

It says the UA-25 sample rate can only be controlled via the hardware
buttons. & the native sample rate is 44.1 Khz:

On the back pane of the UA-25, there is a switch button called "SAMPLE
RATE". The switch has three values: 44.1 Khz, 48 Khz and 96 Khz:

    * In Advance mode OFF, the device will always record/play natively
at the rate of 44.1 Khz using 16 bits.

    * In Advance mode ON, the device will be able to record using 24
bits. Choose the sample rate using the SAMPLE RATE switch

Seems like the hardware ADVANCE MODE switch is OFF, so in that state,
the sample rate will always be 44.1 Khz & both jack & qjackctl are
matching the current hardware sample rate.

But if I'm not telling you anything new, I don't have a clue.


More information about the PlanetCCRMA mailing list