[PlanetCCRMA] Supercollider emacs

James Hearon j_hearon at hotmail.com
Sat Aug 8 18:09:01 PDT 2009

Thanks for help on sc and emacs.  Seems a swingOSC server is running when started alone.

> What happens if you manually do, in a terminal:
> java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -jar
> "/usr/share/SuperCollider/SwingOSC/SwingOSC.jar" -t 57111 -L -i -h

[JCH at localhost ~]$ java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -jar "/usr/share/SuperCollider/SwingOSC/SwingOSC.jar" -t 57111 -L -i -h
-h option requires address specification! (-h <hostName:port>)
SwingOSC v0.61. receiving TCP at address

...but for getting it going with SC with emacs, I'm using a sun jdk with netbeans and eclipse which is in /opt/jdk1.6.0_14/bin, with links to jar, javac, and java in etc/alternatives, paths set in .bashrc, and environ vars pointing to that dir.

Sourceforge.net swingOSC instructions show adding lines to sclang.sc.  How would I go about pointing to a different java with Planetccrma SC-world?  

SwingOSC.java = "/opt/jdk1.6.0_14/bin/java";
SwingOSC.program = ("/usr/share/SuperCollider/SwingOSC/SwingOSC.jar").standardizePath;
for using usb soundcard with SC and emacs
vers. of qjackctl is:

[JCH at localhost ~]$ rpm -q qjackctl

trying to start qjackctl as normal user gives segfault.

[JCH at localhost ~]$ qjackctl
Segmentation fault

I'm using ccrma rpm jack audio connection kit, but have never been able to get qjackctl to work since doing a clean install of f10 recently, and loosing QT4 rpm, which comes now with it's own installer like netbeans, etc.  I tried compiling qjackctl against the new QT4 libs, but it still did not work, so I uninstalled that attempt.  The vers. above seems to be a fedora one, not the ccrma one, which I do not see anylonger in the rpm list.

Jack starts.  Just trying to use the usb sound card from SC and emacs.

> Subject: Re: [PlanetCCRMA] Supercollider emacs
> From: nando at ccrma.Stanford.EDU
> To: j_hearon at hotmail.com
> CC: planetccrma at ccrma.Stanford.EDU
> Date: Sat, 8 Aug 2009 11:37:08 -0700
> On Sat, 2009-08-08 at 18:07 +0000, James Hearon wrote:
> > Hi,
> > re: supercollider/emacs, f10 i386
> > 
> > Thanks for info on swingOSC in supercollider world package. I tried
> > installing that one but still get the same error:
> (did you uninstall your manual install?)
> > ERROR: SwingOSC server not running
> Well, this is the last line in (probably) multiline feedback from
> SuperCollider so it is impossible to know _why_ that is happening. 
> What happens if you do, in a terminal:
> (this is what I get in my fc10 laptop):
> $ which java|xargs ls -l|awk '{print $10}'|xargs ls -l 
> lrwxrwxrwx 1 root root 39 2009-08-07 17:35 /etc/alternatives/java
> -> /usr/lib/jvm/jre-1.6.0-openjdk/bin/java
> What happens if you manually do, in a terminal:
> java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -jar
> "/usr/share/SuperCollider/SwingOSC/SwingOSC.jar" -t 57111 -L -i -h
> (all in one line, this would start the SwingOSC server)
> > ----------------
> > for using a usb soundcard with supercollider/emacs,
> > "cat /proc/asound/cards" shows the order I setup in modprobe file.
> > 
> > 
> >  0 [I82801CAICH3   ]: ICH - Intel 82801CA-ICH3
> >                       Intel 82801CA-ICH3 with AD1881A at irq 11
> >  1 [USB            ]: USB-Audio - Transit USB
> >                       M-Audio Transit USB at usb-0000:00:1d.1-2, full
> > speed
> >  2 [Modem          ]: ICH-MODEM - Intel 82801CA-ICH3 Modem
> >                       Intel 82801CA-ICH3 Modem at irq 11
> > 
> > for running jack with qjackctl, I've not had any luck getting qjackctl
> > to run. 
> > 
> > [root at localhost JCH]# qjackctl
> > Qt: Session management error: None of the authentication protocols
> > specified are supported
> > qjackctl: symbol lookup error: qjackctl: undefined symbol:
> > _ZN8QPainter10drawPixmapERK7QPointFRK7QPixmap
> Two things:
> - which version of qjackctl do you have installed?
>   to find out: rpm -q qjackctl 
> there is something wrong with the versions of packages you have
> installed, qjackctl is not finding a symbol when it tries to start, it
> could be because you have older packages installed than what it needs.
> Have you tried to install it manually in the past?
> - why are you running as root? That is not necessary and certainly not
> recommended. You need to run _everything_ as a normal user (ie: don't
> start something in one account and try to use it from another. 
> -- Fernando

Get back to school stuff for them and cashback for you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://ccrma-mail.stanford.edu/pipermail/planetccrma/attachments/20090809/b04155f6/attachment.html 

More information about the PlanetCCRMA mailing list