[PlanetCCRMA] Supercollider emacs

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Sat Aug 8 11:37:08 PDT 2009

On Sat, 2009-08-08 at 18:07 +0000, James Hearon wrote:
> Hi,
> re: supercollider/emacs, f10 i386
> Thanks for info on swingOSC in supercollider world package. I tried
> installing that one but still get the same error:

(did you uninstall your manual install?)

> ERROR: SwingOSC server not running

Well, this is the last line in (probably) multiline feedback from
SuperCollider so it is impossible to know _why_ that is happening. 

What happens if you do, in a terminal:
(this is what I get in my fc10 laptop):

$ which java|xargs ls -l|awk '{print $10}'|xargs ls -l 

lrwxrwxrwx 1 root root 39 2009-08-07 17:35 /etc/alternatives/java
-> /usr/lib/jvm/jre-1.6.0-openjdk/bin/java

What happens if you manually do, in a terminal:

java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -jar
"/usr/share/SuperCollider/SwingOSC/SwingOSC.jar" -t 57111 -L -i -h

(all in one line, this would start the SwingOSC server)

> ----------------
> for using a usb soundcard with supercollider/emacs,
> "cat /proc/asound/cards" shows the order I setup in modprobe file.
>  0 [I82801CAICH3   ]: ICH - Intel 82801CA-ICH3
>                       Intel 82801CA-ICH3 with AD1881A at irq 11
>  1 [USB            ]: USB-Audio - Transit USB
>                       M-Audio Transit USB at usb-0000:00:1d.1-2, full
> speed
>  2 [Modem          ]: ICH-MODEM - Intel 82801CA-ICH3 Modem
>                       Intel 82801CA-ICH3 Modem at irq 11
> for running jack with qjackctl, I've not had any luck getting qjackctl
> to run. 
> [root at localhost JCH]# qjackctl
> Qt: Session management error: None of the authentication protocols
> specified are supported
> qjackctl: symbol lookup error: qjackctl: undefined symbol:
> _ZN8QPainter10drawPixmapERK7QPointFRK7QPixmap

Two things:
- which version of qjackctl do you have installed?
  to find out: rpm -q qjackctl 

there is something wrong with the versions of packages you have
installed, qjackctl is not finding a symbol when it tries to start, it
could be because you have older packages installed than what it needs.
Have you tried to install it manually in the past?

- why are you running as root? That is not necessary and certainly not
recommended. You need to run _everything_ as a normal user (ie: don't
start something in one account and try to use it from another. 

-- Fernando

More information about the PlanetCCRMA mailing list