[PlanetCCRMA] Midiman Oxygen8 on Fedora 9

Peter Howard pjh at coastal.net.au
Wed Jul 9 17:10:53 PDT 2008

On Sun, 2008-07-06 at 07:44 -0400, Ebrahim Mayat wrote:
> On Sun, 2008-07-06 at 12:14 +1000, Peter Howard wrote: 
> > My old laptop died and when setting up my new (to me) one I decided to
> > go straight to Fedora 9.  Which has been good up to the point I decided
> > to connect my Oxygen8 keyboard.  I discovered to my joy that
> > midisport-firmware is now packaged for Fedora so installed it.
> > Interestingly the current version (1.2) doesn't mention the need to
> > provide the actual firmware as the 0.X version did.  Anyway I plug in
> > the keyboard and it appears to initialise.  But it doesn't appear
> > anywhere.   My normal way of connecting it is via the qjackctl "connect"
> > window.  But it isn't there.  


> Yes, I also have a similar problem with my MIDI interface which I posted to this list previously :

Thanks.  This wasn't my problem (read below), but your details got me
out of my "It's stopped working!!!! I DON'T want to have to think about
this!!!!" mindset :-)

> > OTOH, my MIDI is not fully functional. Virtual onboard MIDI works if
> > I
> > route MIDI events between applications e.g. vkeybd --> softsynth or 
> > aplaymidi ---> kmidimon. There was also no problem in rendering a MIDI
> > file
> > 
> > $ aplaymidi -p 129 MIDIFile.mid (129 = qsynth)
> > 
> > BUT...I am unable to trigger MIDI events from my external MIDI
> > controller.
> > 
> > I suspect that this is because the driver for my FastLane MIDI
> > interface
> > is now broken on F9. (FastLane works on OS X so it's not the hardware
> > device.) While this problem has been documented before, this MIDI
> > interface has been working flawlessly on FC6, FC7 and FC8. So,
> > something
> > has indeed changed. 
> > 
> > Long story short...the hardware MIDI device is recognized in F9 when
> > checked using "amidi -l", "dmesg" and "cat /proc/asound/devices".
> > Also see <http://hg.alsa-project.org/alsa-kernel/log?rev=motu>
> > 
> > The "Messages" window of qsynth, however, returns the following
> > error:
> > fluidsynth: warning: Could not connect to any physical jack ports;
> > fluidsynth is unconnected
> > 
> > 
> > All the relevent modules are loaded:
> > 
> > # lsmod | grep snd
> > 


> > Finally "amidi --dump" does give the following error message:
> > # amidi --dump
> > ALSA lib rawmidi_hw.c:233:(snd_rawmidi_hw_open) open /dev/snd/midiC0D0
> > failed: No such file or directory
> > cannot open port "default": No such file or directory

The fact modules _were_ missing in my list, and the fact that "amidi -l"
crashed, let alone "amidi --dump" confirmed to me that the keyboard
_wasn't_ being initialised.  So then I did what I should have done at
the start - cross check the Vendor/ProdID values given out
of /proc/bus/usb/devices against what was
in /etc/udev/rules.d/81-midisport.rules (as provided by the
midisport-firmware RPM).  And, lo and behold, the Oxygen8 values weren't
in there.


pulling the values out of ye olde midisport_firmware 0.2 (I've confirmed
they're also in the 1.2 you pull directly from sourceforge) and manually
adding them to the rules file solved my problem.  

So from that I can answer my own questions (plus some more)
      * The old hotplug-based midisport-firmare releases (0.x) don't
        work at all with Fedora 9
      * It appears that you no longer need to separately supply the
        firmware blobs - they're there in the 1.X series of
      * The rules file included in the midisport-firmware RPM for F9
        lacks most of the devices listed in the upstream package.

> As a short-term (maybe long-term) fix I re-installed the old
> kernel (with which external MIDI triggering has
> worked flawlessly and still works).

Once it's configured properly, the keyboard is working fine with the kernel.  Don't know if it's relevant to you
or not, but if you were failing on earlier kernels it's worth a try
(note: as of right now all I've done is play the keyboard - no fiddling
with wheels or controllers - just notes).

Anyway thanks again for getting me thinking in the right direction.


More information about the PlanetCCRMA mailing list