[PlanetCCRMA] jack fails to start....

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Sat Sep 1 19:27:02 2007

On Sat, 2007-09-01 at 14:08 -0700, John Lowry wrote:
> Seems to be a bit of this going around :-(
> Last night my usual qjackctl, qsynth, rosegarden sequence worked just fine.
> But not tonight.
> This is what I get:
> 22:49:03.701 Startup script...
> 22:49:03.702 artsshell -q terminate
> JACK tmpdir identified as [/dev/shm]
> 22:49:04.083 Startup script terminated with exit status=256.
> 22:49:04.084 JACK is starting...
> 22:49:04.084 jackstart -R -P2 -dalsa -dhw:0 -r48000 -p512 -n2
> 22:49:04.088 Could not start JACK. Sorry.
> I can't find jackstart anywhere on the disk.  But I notice from other
> submissions that jackd is called.  So I run the jackstart command at the shell
> with jackd, and manage to run qsynth and rosegarden successfully afterwards,
> although qsynth gives error messages about alsa sequencer buffer overrun.
> So what's up with this jackstart vs jackd?  I didn't install any new sofware....
> Or delete any.....

But you changed something - a preference, I don't know how :-) Jackstart
is a very old hack to get jackd started with realtime privileges - from
the 2.4.x times. It is no longer needed. Just set up jackd as the
command to call in qjackctl preferences and all should be well. 

-- Fernando