[PlanetCCRMA] Jack and KDE

Roy Vestal rvestal@trilug.org
Tue May 2 18:31:01 2006

Thanks Nigel. I verified arts is disabled. I also tried it with TWM...no 
good. Here's what you suggested i post:

0 [S16            ]: SB16 - Sound Blaster 16
                     Sound Blaster 16 at 0x220, irq 5, dma 1&5
Advanced Linux Sound Architecture Driver Version 1.0.9rc1.
Compiled on Mar 22 2005 for kernel 2.6.10-2.1.ll.rhfc3.ccrma.

Module                  Size  Used by
mga                   125444  2
realtime                5128  0
commoncap               8064  1 realtime
parport_pc             29380  0
lp                     12780  0
parport                42440  2 parport_pc,lp
autofs4                28932  0
sunrpc                186724  1
ipt_REJECT              7168  1
ipt_state               1792  1
ip_conntrack           45748  1 ipt_state
iptable_filter          3584  1
ip_tables              18944  3 ipt_REJECT,ipt_state,iptable_filter
dm_mod                 64148  0
video                  15620  0
button                  6416  0
battery                 9220  0
ac                      4740  0
md5                     4096  1
ipv6                  284864  8
uhci_hcd               36368  0
i2c_viapro              7436  0
i2c_core               23040  1 i2c_viapro
ns558                   5504  0
gameport                5120  1 ns558
snd_sb16               13544  0
snd_opl3_lib           14464  1 snd_sb16
snd_sb16_dsp           19072  1 snd_sb16
snd_pcm_oss            65312  0
snd_mixer_oss          21760  1 snd_pcm_oss
snd_pcm               124296  2 snd_sb16_dsp,snd_pcm_oss
snd_timer              38276  2 snd_opl3_lib,snd_pcm
snd_page_alloc         10884  1 snd_pcm
snd_sb16_csp           28160  1 snd_sb16
snd_sb_common          22272  3 snd_sb16,snd_sb16_dsp,snd_sb16_csp
snd_hwdep              10912  2 snd_opl3_lib,snd_sb16_csp
snd_mpu401_uart        11136  1 snd_sb16
snd_rawmidi            33696  1 snd_mpu401_uart
snd_seq_device          9740  2 snd_opl3_lib,snd_rawmidi
snd                    76164  13 
soundcore              11360  1 snd
e100                   50816  0
mii                     5120  1 e100
floppy                 66992  0
ext3                  135560  2
jbd                    92184  1 ext3

This is an older SB16 PnP ISA card. I gotta feeling the problem is the card
No modems nor such

Here's the exact error when I run qjackctl:

JACK compiled with System V SHM support.
loading driver ..
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames, buffer = 2 periods
Couldn't open hw:0 for 32bit samples trying 24bit instead
Couldn't open hw:0 for 24bit samples trying 16bit instead
Sorry. The audio interface "hw:0" doesn't support any of the hardware 
sample formats that JACK's alsa-driver can use.
ALSA: cannot configure capture channel
cannot load driver module alsa
no message buffer overruns

Again, many thanks. And if it's the hardware, I'll just have to break 
the bank and buy a Delta

Nigel Henry wrote:

>On Monday 01 May 2006 21:51, Roy Vestal wrote:
>>Over the weekend I tried this, killing artsd, and setting it NOT to
>>start. Didn't work. I still get the hw:0 busy error, but now it's saying
>>"no alsa-driver found for this hardware". *sigh*
>>It's a SB16 PnP, and according to www.alsa-project.org it's supported...
>>Jan Depner wrote:
>>>Make sure you kill -9 artsd prior to starting jackd.  I usually put that
>>>in my qjackctl startup script.
>>>On Wed, 2006-04-26 at 09:13 -0700, Fernando Lopez-Lezcano wrote:
>>>>On Wed, 2006-04-26 at 09:20 -0400, Roy Vestal wrote:
>>>>>I'm getting an error starting Jack in my KDE environment. This is a new
>>>>>install/build of FC3 and I'm wondering if ARTS is turned on. I'm
>>>>>assuming this would be the cause of my Jack start errors. I believe the
>>>>>error is "jackd could not start hw:0 in use". At the time of this
>>>>>writing I am not able to get to the machine for the exact error.
>>>>>My question: Can ARTS be active and jackd still work or does it need to
>>>>>be off? I'm assuming off is the correct answer at this time.
>>>>Jack normally takes complete ownership of the sound card, all other
>>>>programs that use it have to be "off".
>>>>-- Fernando
>Hi Roy. I don't know if I can help much. I looked on my FC3 install, and in.
>/lib/modules/2.6.11-0.3.rdt.rhfc3.ccrma/kernel/sound/isa/sb  , the snd-sb16 
>module is there.
>It's worth checking in Control centre/Sound & Multimedia/Sound System, that 
>the "Enable the sound system" box is unchecked, if it isn't, make sure to 
>click on apply after unchecking it. 
>Perhaps you'd post a few things.
>cat /proc/asound/cards
>cat /proc/asound/version
>/sbin/lsmod    (to check out if the snd-sb16 is on the list, and to see if 
>anything else is there that might be interfering with it) .
>/sbin/lspci      (to see if there are, either onboard, or pci modem cards) I'm 
>clutching at straws on this one, as I don't know if the sound driver on modem 
>cards would result in these problems.
>Leaving Jack out of the equation, does Alsa work? Can you play a music cd? Can 
>you play a demo track in Hydrogen, with it setup to use Alsa, and not Jack? 
>Try stopping and starting Alsa, and see if there are any error messages.
>/etc/rc.d/init.d/alsasound stop
>/etc/rc.d/init.d/alsasound start
>It's worth also running ps auxw on the CLI. See if there's anything audio 
>related running that you were unaware of.
>You can have a look in /etc/sysconfig , under, class: Audio, to verify the 
>driver for your card.
>Probably all of this is of little help, but worth a look. It might just be 
>best to get another card. A cheap SB Live, but make sure it's one using the 
>emu10k1 driver, but as the SB16 is supported it should work, even though a 
>bit old.
>>>>PlanetCCRMA mailing list
>>PlanetCCRMA mailing list