[PlanetCCRMA] Jack and KDE

Nigel Henry cave.dnb@tiscali.fr
Tue May 2 08:29:00 2006

On Monday 01 May 2006 21:51, Roy Vestal wrote:
> Over the weekend I tried this, killing artsd, and setting it NOT to
> start. Didn't work. I still get the hw:0 busy error, but now it's saying
> "no alsa-driver found for this hardware". *sigh*
> It's a SB16 PnP, and according to www.alsa-project.org it's supported...
> Ideas?
> Jan Depner wrote:
> >Make sure you kill -9 artsd prior to starting jackd.  I usually put that
> >in my qjackctl startup script.
> >
> >On Wed, 2006-04-26 at 09:13 -0700, Fernando Lopez-Lezcano wrote:
> >>On Wed, 2006-04-26 at 09:20 -0400, Roy Vestal wrote:
> >>>I'm getting an error starting Jack in my KDE environment. This is a new
> >>>install/build of FC3 and I'm wondering if ARTS is turned on. I'm
> >>>assuming this would be the cause of my Jack start errors. I believe the
> >>>error is "jackd could not start hw:0 in use". At the time of this
> >>>writing I am not able to get to the machine for the exact error.
> >>>
> >>>My question: Can ARTS be active and jackd still work or does it need to
> >>>be off? I'm assuming off is the correct answer at this time.
> >>
> >>Jack normally takes complete ownership of the sound card, all other
> >>programs that use it have to be "off".
> >>
> >>-- Fernando

Hi Roy. I don't know if I can help much. I looked on my FC3 install, and in.
/lib/modules/2.6.11-0.3.rdt.rhfc3.ccrma/kernel/sound/isa/sb  , the snd-sb16 
module is there.

It's worth checking in Control centre/Sound & Multimedia/Sound System, that 
the "Enable the sound system" box is unchecked, if it isn't, make sure to 
click on apply after unchecking it. 

Perhaps you'd post a few things.
cat /proc/asound/cards
cat /proc/asound/version
/sbin/lsmod    (to check out if the snd-sb16 is on the list, and to see if 
anything else is there that might be interfering with it) .
/sbin/lspci      (to see if there are, either onboard, or pci modem cards) I'm 
clutching at straws on this one, as I don't know if the sound driver on modem 
cards would result in these problems.

Leaving Jack out of the equation, does Alsa work? Can you play a music cd? Can 
you play a demo track in Hydrogen, with it setup to use Alsa, and not Jack? 
Try stopping and starting Alsa, and see if there are any error messages.
/etc/rc.d/init.d/alsasound stop
/etc/rc.d/init.d/alsasound start

It's worth also running ps auxw on the CLI. See if there's anything audio 
related running that you were unaware of.

You can have a look in /etc/sysconfig , under, class: Audio, to verify the 
driver for your card.

Probably all of this is of little help, but worth a look. It might just be 
best to get another card. A cheap SB Live, but make sure it's one using the 
emu10k1 driver, but as the SB16 is supported it should work, even though a 
bit old.


> >>
> >>
> >>_______________________________________________
> >>PlanetCCRMA mailing list
> >>PlanetCCRMA@ccrma.stanford.edu
> >>http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma