[PlanetCCRMA] alsa-lib breakage

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Wed Jan 25 15:24:00 2006

On Wed, 2006-01-25 at 22:28 +0000, David Beetham wrote:
> A question re: alsa-lib
> I have tried to upgrade my version of the alsa-lib today but synaptic
> complains with the following message
> alsa-lib:
>   Depends: alsa-driver (>=1.0.10) but 1.0.9b-1.rhfc4.ccrma is to be
> installed
>  Depends: config(alsa-lib) (= 1.0.10-3.1.rhfc4.ccrma)

What version of alsa-driver do you have in the apt cache?
  apt-cache policy alsa-driver
and it would also be interesting to know:
  apt-cache policy alsa-lib

> Is there an easy fix to this problem ?

Argh, two mistakes on my part, I think. The new alsa-lib was transferred
to the wrong repository (planetccrma instead of planetcore - I just
fixed that). And the alsa-lib package requires a newer version of
alsa-driver than the one included in the standard repository. I will
build a new alsa-lib package that does not have that dependency so that
it will be installable with older versions of the kernel/alsa-driver.
Expect it online shortly...

-- Fernando