[PlanetCCRMA] FC4 on an older machine?

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Wed Feb 22 18:39:01 2006

On Wed, 2006-02-22 at 18:16 -0800, Len wrote:
> I've been running FC1 (2.4.26-1.ll.rhfc1.ccrma) on an older machine:
> P3 800MHz processor
> 512MB RAM
> 19GB primary HD
> 40GB secondary (audio)
> Echo Layla 24/96 audio interface (PCI slot 2, not shared - IRQ 10)
> Graphics integrated in MOBO (64MB)
> I dual-boot Windows and Linux, and the audio drive is formatted as FAT32 so it can be accessed
> from either OS.
> I've gotten decent results, and multi-tracking in Ardour hasn't been a problem.  Most of the stuff
> I've recorded by myself, and I've played all the instruments and vocal tracks, so I never used
> more than a few tracks simultaneously, though I've overdubbed lots more tracks, up to 10 or so. 
> No problems.
> Recently, I racked my computer and took it over to a friend's house to record our band.  I enabled
> 7 or 8 tracks and hit record.  After a few seconds of recording, Ardour tells me that "the disk
> was not able to keep up with Ardour" and the recording is hosed.

Have you checked to see if dma is turned on for the hard disk you are
using to record?

  hdparm /dev/hdx (where x is your hard disk)

Should tell us more..
I have not tried fat32 so I don't know about its performance. 
-- Fernando

> Since I haven't tried recording this many tracks at the same time, I don't know if this is a new
> problem or if it's been there all along.  I guess it's possible that the audio disk format (FAT32)
> is a contributing factor.  I added a USB2.0 PCI card a while back, and no matter what I do it
> wants to share an IRQ with Layla (even if I assign Layla to a different IRQ).  I haven't tried
> removing the USB card and recording, but I guess that would be a no-brainer and something I should
> have tried already.
> I am considering the move up to FC4.  Is my system up to it?  Anyone running FC4 successfully on
> an older machine with good results?