[PlanetCCRMA] Re: From zero to DAW in 2 hours !

David Slimp rock808@gmail.com
Fri Feb 17 17:46:01 2006

You're right!  -- I didn't catch that the error WAS/IS  right
after upgrading the FC4 (non-ccrma) packages!

However, he IS getting that after installing the new packages/kernel,
but not booting in to it yet!?

So, Bal..... this seems a bit weird.
If you feel up for tracking down the problem, I'd say do the
install again... right after install, then log in, and do "init 6"
for reboot.... do that 4-5 times to make sure every time reboots

if you get NO kernel panics, then install the ccrma kernel/alsa only:
rpm -Uvh http://ccrma.stanford.edu/planetccrma/apt/rpms/apt-0.5.15cnc6-4.rhfc4.ccrma.i386.rpm
rpm --import http://ccrma.stanford.edu/planetccrma/RPM-GPG-KEY.planetccrma.txt
apt-get update
apt-get install planetccrma-core-edge

After doing that... "init 6"
Does init 6 NOW give kernel panic??

After rebooting, load the ccrma kernel, and run with that.
Again, do "init 6" about 5 times... any kernel panics these times?

If not, then there's probably something bad with some other
packages, and we should try installing just a few at a time and
rebooting, to narrow it down.


On 2/17/06, Fernando Lopez-Lezcano <nando@ccrma.stanford.edu> wrote:
> On Sat, 2006-02-18 at 00:45 +0000, Bal Dobe wrote:
> > Fernando,
> >
> > Thanks for your time and comments on this issue.
> >
> > OK lets try and think this through logically, please bear with me on this I
> > am relatively new to  Linux and am still learning.
> >
> > Kernel Panic problem;
> > FC4 installs on my machine fine, I can also install all the ccrma audiovideo
> > apps.  Following David's instructions DAW in 2 hours I do not get an error
> > at the first reboot,via init 6
> >
> > So I install FC4:
> >
> > "just have auto partitioning.... don't select "selinux".
> > .. everything just very generic.
> (selinux is probably not related to the problem you are having)
> > start the GUI, but don't change to KDE
> > for now... just do an "init 6" and see if you get that same error.
> > Hopefully you'll reboot just fine."
> >
> > I was able to reboot after the FC4 install.
> >
> > Then I did the planet ccrma installs
> >
> > "Log in again, and only upgrade the FC4 stuff first:
> > rpm -Uvh
> > http://ccrma.stanford.edu/planetccrma/apt/rpms/apt-0.5.15cnc6-4.rhfc4.cc
> > rma.i386.rpm
> > rpm --import
> > http://ccrma.stanford.edu/planetccrma/RPM-GPG-KEY.planetccrma.txt
> > apt-get update
> > apt-get upgrade"
> >
> > After this is done I get the kernel error.
> Wait, at this point you have _not_ installed the Planet CCRMA kernel
> (that would be "apt-get install planetccrma-core-edge" followed by a
> reboot to try it out) and you have not installed the Planet CCRMA
> packages (that would be "apt-get install planetccrma-audioapps", or one
> of the other meta packages). If that is all you did you have just
> upgraded mostly Fedora Core packages.
> > The problem is repeatable, it has happened several times now.
> Sorry, I'm still unclear on exactly when the problem is happening.
> The important thing is: which kernel are you running just before you get
> the kernel panic? (if it is a kernel panic).
> To find out which kernel you are running type: "uname -r" _before_
> triggering the problem. As I said before it is unlikely that the problem
> is ram (specially after you have tested it with memtest86).
> If the kernel printed by uname contains the string "rhfc4.ccrma" in the
> release part then it is a Planet CCRMA kernel, otherwise you are still
> running the Fedora Core kernel.
> Just a quick question: when the kernel panic happens the machine goes
> completely catatonic, right? And the only option you are left with is
> the reset button or a power cycle? Just to make sure it is indeed a
> kernel panic (or a similar kernel problem). After you reboot from it you
> may find traces of the problem in the system log (/var/log/messages),
> search for the word "Oops" there.
> > RAM problem.
> > Surely bad ram is bad ram so FC4 should not be able to work not just FC4
> > ccrma, or am a mistaken?
> >
> > I am doing a memtest86 on my machine at the moment, the machine is over a
> > year old and was thoroughly tested continuously for about 2 days, upon being
> > built. No Ram errors were found. There are still no errors after 30 mins and
> > one pass.
> Then probably the ram is fine.
> First we have to determine what kind of problem you are having, and
> under which kernel. If it is indeed a kernel problem triggered by a bug
> somewhere in it the solution is, sorry, don't run that kernel :-)
> -- Fernando
> > If this is the problem, how can I fix it? Buy new ram, how do I know that
> > will work? Can I just buy more ram and continue to use the ram I have in
> > conjunction with the new ram?
> >
> > As you can see I seriously hope that it is not a ram issue.
> >
> > Alternative solutions.
> >
> > Load FC4 on another HDD?
> > Could the problem be the HDD?  I have three HDDs in the machine and I am
> > only using linux on one Maxtor 200Gig drive?  I also have a Seagate, should
> > I try and do a reinstall on the Seagate drive and see if that makes any
> > difference?
> >
> > If it works on the Seagate then I would be happy to move all of my windows
> > applications to the Maxtor 200G drive and use the Seagate for linux.
> >
> > Reinstall FC3 and ccrma for FC3?
> > Should I try and install FC3 an do a ccrma install on that?  Can I install
> > that on one of my other partitions without upsetting the FC4 install?
> > Remember I had problems with the sound on the FC3 install.
> >
> > Is the FC3 ccrma install more stable albeit with latency not as good as FC4?
> > I am happy to wait for FC4 to be sorted out and use FC3 in the meantime.
> > Could I leave my FC4 install and start using a FC3 ccrma kernel?
> >
> > Hope that somebody can help.

David Slimp

"On proprietary platforms, eventually you'll run into 'you can't do that.'
 On open platforms, you'll run into 'you have to learn more to do that.' "
 -- Ian Smith-Heisters